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Configuration Management
HiCAD offers a central configuration management via the Configuration Editor. This tool allows the creation of
customer-specific configurations for a wide range of tasks, such as dimensioning, annotation, workshop draw-
ing creation, fitting of vertical ladders etc. Once adjusted to company-specific requirements, these con-
figurations can directly be used in HiCAD, without having to specify any further settings.

The goal of our further developments is a gradual transfer of the previously used system files (*.DAT) with their
adjustable parameter settings into the Configuration Editor, thus enabling a central and safe configuration man-
agement.

You can find an overview of the already transferred DAT files in the topic Transfer of DAT Files to the Con-
figuration Editor or in the PDF file Key names.pdf.

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link
and select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the
PDF file ISD-Configuration.pdf.

Scope
n Hierarchical management of configuration data in the form of module properties

Settings are assigned to modules and sub-modules in a tree-like structure, and represent properties defin-
ing the Behaviour of a module. The categorization facilitates the retrieval of individual settings.

n Central data storage

The configuration data are centrally stored in a database file in a defined location within the user system,
which enables an easy backing up, restoring or copying of data.

n User-specific data storage

The property definitions are stored separately from the actual user settings. This allows a working in multi-
user environments while eliminating the risk that a user accidentally manipulates the configuration of other
users.

n Derived configurations

Configuration Management allows, in addition to the basic configuration supplied by the ISD, the utilisation
of further, derived configurations for a definition of company- and/or team-specific settings. Furthermore,
you have the option to offer to users alternative configurations within one derivation level.

n Central administration of settings via one common graphical Configuration Editor

Eliminates the need for time-consuming and error-prone manipulations in configuration files. The integ-
rated validation of setting values by ranges and selection lists minimizes the risk of incorrect configurations
and system crashes due to invalid values.

n Documentation of settings

Each setting has a multi-language short description and comments on the meaning of the setting values.
The Configuration Editor offers a full text search for property names, descriptions and comments.

n Update-ability of the database

The data storage in the form of user profiles enables an updating of underlying pre-settings, without having
to change existing user settings. Values that have not been changed by the user will automatically be
assigned the updated pre-settings.
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Important:

Please note that the scope of functions available to you depends on the configuration level of your product, i.e.
not all the functions described in the Help may be available in your product!

The range of selectable modules for a local license depend on the license that was purchased.
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Transfer of DAT Files to the Configuration Editor
As of Version 1700, HiCAD enables a central configuration management via the Configuration Editor. This
tool allows the creation of customer-specific configurations for a wide range of tasks, such as dimensioning,
annotation, workshop drawing creation, fitting of vertical ladders etc. Once adjusted to company-specific
requirements, these configurations can directly be used in HiCAD, without having to specify any further set-
tings.

The goal of our further developments is a gradual transfer of the previously used system files with their
adjustable parameter settings into the Configuration Editor, thus enabling a central and safe configuration man-
agement.

This transfer has already been realised for the following files:

n ALGPAR.DAT (as of 1800.0)

n BEMPAR.DAT (as of 1800.0)

n DIMENSIONING_SETTINGS.XML (as of 1800.0)

n STBEMPAR.DAT (as of 1801.0)

n KRPGEN.DAT (as of 1801.0)

n MASPAR.DAT (as of 1801.1)

n FITTABLE_SETTINGS.XML (as of 1801.0)

n TXTANSI.DAT (as of 1801.1)

n STABMPAR.DAT (as of 1802.0)

n AUBM3PAR.DAT (as of 1802.0)

n ALG3DPAR.DAT (as of 1901.0)

n SCHRIF.DAT (as of 1901.0)

n TXTFONT.DAT (as of 1901.0)

n FEATURE.DAT (as of 1901.0)

n LINPAR.DAT (as of 1901.0)

n SSWRITESTEP.DAT (as of 1901.0)

n NORM.DAT (as of 2000.0)

n PASSTAB.DAT (as of 2000.0)

n PASSTAB0.DAT (as of 2000.0)

n ANSGEN.DAT (as of 2100.0)

n PARAMASS.DAT (as of 2101)

n SSTINI3D.DAT (as of 2102)

n SSTINI.DAT (as of 2102)

n STB_PARAMETER.DAT (as of 2102)

n GRAPAR.DAT (as of 2201)

n KNTPAR.DAT (as of 2202)

n REF3D_ATTR_AKT.DAT (as of 2300)

n TXTPAR.DAT (as of 2300)
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bempardatkm.htm
stbempardatkm.htm
krpgendatkm.htm
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stabmpardatkm.htm
aubm3pardatkm.htm
alg3dpardatkm.htm
schrifdatkm.htm
txtfontdatkm.htm
featuredatkm.htm
linpardatkm.htm
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normdatkm.htm
passtabdatkm.htm
passtabdatkm.htm
ansgendatkm.htm
paramassdatkm.htm
sstini3dkm.htm
sstinikm.htm
stbparameterdatkm.htm
grapardatkm.htm
kntpardatkm.htm
ref3d_attr_aktdatkm.htm
txtpardatkm.htm


n TABPAR.DAT (as of 2400)

n ABWPAR.DAT (as of 2402)

n ABWCOL.DAT (as of 2402)

n ABWPOL.DAT (as of 2500)

n KRPMOD.DAT (as of 2700)

n SKIZZTEC.DAT (as of 2701)

The settings from the files were transferred to the Configuration Editor. The linked lists or the PDF file shows
you where to find the settings from the DAT files in the Configuration Editor (Key names).

Key names.PDF

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link
and select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the
PDF file ISD-Configuration.pdf.
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User Interface
The Configuration Editor enables an editing and managing of configuration. It provides a generic, hierarchical
view of the data and structures contained in the database.

You start the Configuration Editor outside of HiCAD, by executing the file ISDCONFIGEDITOR.EXE in the
EXE directory of HiCAD.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

Users without administrator rights and users with administrator rights who did not select the Run as admin-
istrator option upon start:

n In the Editor, settings can be edited in the profile of the user who is currently logged on Windows.

n The switching to a different user is not possible. The selection box is greyed out.

Users with administrator rights who have selected the Run as administrator option (right-click and select from
context menu) upon start:

n The administrator profile can be changed in the Editor.

n The switching to other existing profiles is possible via the selection box, which enables a checking and/or
changing of the configurations of various users.

You can also start the Configuration Editor directly from HiCAD: At the top right corner of the HiCAD window,
select Settings > Configuration.

You require administrator rights to start the Configuration Editor!

The user interface of the Configuration Editor consists of the following areas:

1. Menu bar

2. Toolbar

3. Search function

4. User selection
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5. Current configuration structure tree

6. Data record of active configuration

7. User Management

8. Path of the currently selected structure item

9. Version and name of the configuration database

Important:

Changes in the Configuration Editor will only take effect after you re-start HiCAD. Only some particular set-
tings, such as dimensioning pre-settings, can be applied, via the corresponding HiCAD functions, without a re-
start.

Menu Bar
The menu bar of the Configuration Editor contains the following menus:

n File

n Edit

n View

n Extras

Please note:

Some of the function in the menus will only be active when a data record has been selected in the right pane of
the window.

File

Export and import of setting values
The structure and the values of the configuration can be written to a XML file with the Export function. The
export function refers to the currently selected item in the configuration tree. The exported settings can then be
imported, for example, to another configuration database.

Edit
The configuration database administers values on the basis of user-specific setting profiles.

When you select a data record in the tree structure in the left pane of the dialogue window, the corresponding
settings will be displayed in the right pane of the window. You can use the functions of the Edit menu to modify
these values and the tree structure.

The changes will take effect after you re-start HiCAD.
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Function Description

Change If you want to change a value in a data record, activate the desired item and select
Change.
You can also activate the value via double-click or by pressing the F2 key, and then
overwrite it.
Changed values, i.e. values deviating from the underlying profile level, are marked
appropriately and can be reset to the original default value at any time.

Reset This function restores the values in the active directory to the state in the database.
For instance, if you have modified the default settings of the dimensioning rules in
various directories, you can right-click the Usage-dependent entry, choose Reset,
and, after confirming the security prompt with, restore the modified settings to
defaults again. If you confirm with Yes, a backup ([Installation directory] > Con-
figuration > HiCAD.cfgdb.[Date]) will be created, in case you may require the mod-
ified settings later again. If you choose No, the values will be reset without creating a
backup.
If you have marked only one value, only this value will be reset.

Copy key Use this function to copy the names of the marked key values in the right window, for
example, to a TXT file.

Rename Use this function to rename derived structures and derived configurations in the tree

structure. The derived structure will be identified by the icon.

Delete This function deletes only derived structures and derived configurations in the left
pane of the Configuration Editor.

Derive structure Use this function to copy the selected branch in the tree structure and paste it with a
different name.

Select reference If a referenced structure has been activated, this function activates the reference.

Activate con-
figuration

The 2nd level of the tree structure in the left pane of the Configuration Editor consists
of the areas:

n Active configuration and

n Configurations.

The configuration that you activate with this function will be displayed in the Active
configuration area and can then be modified.

Derive con-
figuration

Use this function to derive an alternative, complete configuration.
Here, too, the same principle as for structure derivation applies: Unchanged settings
inherit their values from the default values (ISD or Administrator profile) of the super-
ordinate configuration.
To edit the derived configuration, select Activate configuration.

Derive Configuration
Derived configurations have a tree-like structure and function according to the same principle as the over-
laying of values in user profiles, i.e. unchanged settings will inherit their values from the default values (ISD or
Administrator profile) of the superordinate configuration. Configurations on the same derivation level are inde-
pendent from each other.

To derive configurations, select Edit > Derive configuration. Derived configurations will be displayed in the left
pane of the window, under HiCAD >Configurations. The derivation will be created from the currently active
configuration.
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To edit a derived configuration, select Edit > Activate configuration. The derived configuration will then be dis-
played under HiCAD > Active configuration and can be edited.

Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only cre-
ate derivations of company-specific configurations. To restore the ISD default settings, the configuration data-
base (HiCAD.cfgdb) must be re-installed.

Derive Structure
Referenced and derived structures generate value inheritance lines. This enables you to create tree units (or
individual settings) that refer to a reference tree unit and obtain unchanged values initially from the default val-
ues of the reference.

Example: Creation of a new drawing frame for workshop drawings

1. In the tree structure, select ... > Drawings > Drawing frames > DIN_A0. Then select Edit > Derive struc-
ture.

2. Change the displayed key to Drawings.Drawing frames.DIN_A5.

The structure DIN_A5 that will be created now will initially inherit all values from the reference structure DIN_
A0. This means that if one of the default values of DIN_A0 will be changed, this value will also change for DIN_
A5. The values of DIN_A5 can be assigned new default values. If a default value in the derived structure has
been changed, the value from the reference structure will no longer be inherited, i.e. changes of the cor-
responding value in the reference structure will no longer affect the derived value.

Use the Copy values option to take over changed values from a data record that is linked to DIN_A0, e.g.
DIN_A3.

Updates of the reference structure containing new or deleted settings will be adopted by the derived struc-
ture.

View

Update
If you change the configuration settings in HiCAD while the Configuration Editor is open, the new settings will
only be displayed after activating the Update function.
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Example:

When saving the rules set, the rules will be transferred to the Configuration Editor. The rules which are stored
there will be adjusted accordingly, new rules are added, or existing rules are deleted if required. After selecting
Update, the changes will become visible in the Configuration Editor.

Please note that HiCAD will apply the changes from the configuration management only after restart.

Display key names
HiCAD uses the key name to access the settings of the configuration management. The key name is identical
in all languages.

A description of this name is displayed in the standard view.

View mode
The view mode enables the precise displaying of changed settings in the Configuration Editor.

Normal All settings will be displayed in the Configuration Editor.

Only
changed val-
ues

Only changed values of the current user profile, which are marked with the pencil icon
, will be displayed.
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Only
changed
default set-
tings

This view mode is only activated if settings in the ISD profile were changed in an update
and differ from the company-specific default settings in the Administrator profile.

The company-specific Administrator profile will be saved in a logl file during an update.
Afterwards the changed/new settings will be loaded into the ISD profile. At the end the
logl file will be loaded into the Administrator profile again.

If you load the company-specific Administrator profile after the update and select the
Only changed default settings function only the changed settings will be displayed. The
values of the changed settings stem from the company-specific Administrator profile.

When right-clicking on the value the Reset function can be activated. The setting from the
ISD profile which has been changed in the update will be displayed.

Extras

Language
Here you can choose between the different languages.

Units
Here you can set for the Configuration Editor whether the specified values for lengths and weights are to be dis-
played in metric units (millimetres and kilograms) or in imperial units (inches and pounds).

The numbers are displayed rounded with the following unit. When editing the values, there is no rounding, but
the numbers are displayed exactly.
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The setting of the units of measurement only affects the display in configuration management. When con-
structing in HiCAD, the values are always converted into the unit of measurement of the drawing.

Database directory
With a HiCAD standard installation, the database of the configuration management is stored in the HiCAD
installation directory at...\Configuration\HiCAD.cfgdb.

The location of the database file is entered in the Windows Registry at

HKEY_ LOCAL_ MACHINE\SOFTWARE\ISD SOFTWARE UND SYSTEME\HICAD\
[VERSIONSNUMMER]\HICAD.CFGD

and can be changed to another directory in the Configuration Editor via the menu item Extras, optionally by
copying the current database to the new location.

Toolbar
To enable a quick access, some of the functions of the menu bar are also contained in the toolbar:

Change If you want to change a value in a data record, activate the desired item and
select Change.

Reset This function restores the selected value to the state in the database.

Update If you change the configuration settings in HiCAD while the Configuration
Editor is open, the new settings will only be displayed after activating the
Update function.

Collapse all This function collapses the structure display of the Configuration Editor and
shows only the 1st level.

Expand 2
levels

Shows you the first 2 levels of the configuration structure.
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Expand 3
levels

Shows you the first 3 levels of the configuration structure.

Expand all Expands the complete structure display of the Configuration Editor.

Search Function
The Configuration Editor offers a full text search for value descriptions, comments and setting names. During
the process, the Editor browses through the structure, beginning (or continuing) at the currently selected node
of the configuration tree. Enter the desired search term and click the Find icon.

Search for data records
To perform a targeted search for particular entries (e.g. font or font size) in other data records, right-click the
desired data record and select Search value.

In the search mask you can limit the search to a particular area of the configuration structure tree, by activating
the Limit to checkbox and selecting the area of the configuration structure from the drop down menu.
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When you click the Find button, HiCAD will jump to the next data record that meets the specified search cri-
teria. You can change this data record if desired, and continue your search.

User
The configuration database manages values on the basis of user-specific setting profiles. Two pre-defined pro-
files, namely ISD and Administrator, have a special function.

The ISD profile forms the basis for the settings. In this profile, the HiCAD settings preset by the ISD are con-
tained.

The Administrator profile allows the creation of company-wide default settings deviating from the ISD defaults.
In the process, the Administrator profile constitutes a level overlaying the ISD profile: Unchanged values will
be read from the ISD profile, so that changes of the ISD settings will automatically be transferred to the Admin-
istrator profile (and thus also to the superordinate user profiles) when being updated. Modified, company-spe-
cific values will however be retained.

Profiles of other users overlay the Administrator profile according to the same principle, with each user profile
being independent of the other user profiles. If setting values are written from HiCAD into the database, this
process will always be performed via the profile of the user name currently logged on to Windows. In this way,
an accidental changing of user settings, company-wide settings, or ISD default settings by other users via
HiCAD will be prevented.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

n Users without administrator rights and users with administrator rights who did not select the Run as admin-
istrator option upon start:

l In the Editor, settings can be edited in the profile of the user who is currently logged on Windows.
l The switching to a different user is not possible. The selection box is greyed out.

n Users with administrator rights who have selected the Run as administrator option (right-click and select
from context menu) upon start:

l The administrator profile can be changed in the Editor.
l The switching to other existing profiles is possible via the selection box, which enables a checking
and/or changing of the configurations of various users.

To edit an entry, double-click a cell in the Value column, or select a cell and press the F2 key, or click the
Change icon on the Toolbar.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately can be reset
to the original default value at any time.

User Management
The integrated User Management allows the creation and deletion of user profiles, as well as the deletion or
the taking over of user-specific values into other user profiles. In this way, for example, an Administrator is
enabled to specify settings via HiCAD managed in the Configuration Editor. These are initially saved in his/her
Windows user profile, and can later be taken over to the administrator profile as company defaults, and will
then apply to all users.
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Click the icon to call the User Management. The dialogue window is composed of the following tabs:

n Settings

n User

n Groups

Click the icon to close the dialogue window.

Important:

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started.

Settings

Activate the Same configuration for all users checkbox to switch off the User Management and the Per-
missions Management. The settings will then always be written to the Administrator profile.

The User Management is by default deactivated when the configuration database is installed for the first time.

18 / 36 HiCAD Configuration Management

User Interface



User

User tab

Add Adds a new User to the table.

Rename Enables you to change a selected User name.

Delete Deletes the selected User without any further confirmation prompt.

Group assign-
ment

The user rights are controlled via group assignments. A User can belong to several
Groups. Use the Group assignment button to select Groups for Users. The main
Group of the User will be highlighted if you mark this Group and then click the As
default button. The main Group will be available during the configuration selection of
the User. Click OK to exit the Group selection.

Adopt values Use this function to apply the values of a selected User to the active User.

Delete values Deletes the changed values of the selected User, thus restoring the values to that of
the administrator profile / the values preset by the ISD.

Table column:
Active con-
figuration

The Configuration Editor allows the creation of different user configurations via the
Derive configuration function. One of these configurations and the Base con-
figuration can be assigned to the User in the Active configuration column.

Please note:

HiCAD will use the Windows Login name in case of an utilisation via HiCAD, i.e. these names need to match
when users are created.
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Groups

Group tab

Add Adds a new Group to the table.

Rename Enables you to change a selected Group name.

Delete Deletes the selected Group without any further confirmation prompt.

Table column:
Active con-
figuration

The Configuration Editor allows the creation of different user configurations via the
Derive configuration function. One of these configurations and the Base con-
figuration can be assigned to the Group in the Active configuration column.

Permissions for:
e.g. Designers A

The rights of a Group can be specified in the Permissions for: ... area, by activating
the corresponding checkboxes. If a User belongs to several Groups, the activated
rights of these additional Groups are also available to him/her.

The permissions enable you to specify, for example, that a User can only read the
settings defined by the administrator, but not define and save his/her own settings,
thus ensuring company-wide, identical settings.

Please note:
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n The permissions that are assigned here apply globally, i.e. for all Users of the Group.

n Use the Permissions function if you want to assign permissions for sub-trees of the configuration. You can
then define permissions for Users and Groups .

Configuration Structure
The left pane of the Configuration Editor dialogue window contains the following entries (below HiCAD):

n Active Configuration and

n Configurations.

Under Active configuration you will find the current HiCAD settings.

Under Configurations you can find the base configuration and all derived configurations of the active user.
Use the Derive configuration function to load data into the Active configuration area. There, you can activate
individual data records and edit them in the right pane of the dialogue window.

Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only cre-
ate derivations of company-specific configurations. To restore the ISD default settings, the configuration data-
base (HiCAD.cfgdb) must be re-installed.

Data Record
In the right pane of the Configurator Editor you can edit the data records that you activate in the left pane of the
window. The data record consists of the Description, the Value and the Comment. When you display the key
name via View > Display key names, the system name of the entry will be additionally displayed.

You define your individual profile for HiCAD via the setting of values. The values are not always numerical val-
ues. They may also be:

n a unit of measurement (mm, cm, ...)

n a string ("Collection")
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n a key name

n a free entry

n a checkmark (e.g. to activate the display of a query etc.)

n a procedure (Always, Dependent on dimension plane, etc.)

n an entry from the Catalogue Editor

n a selection of attributes.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately and can be
reset to the original default value (right-click and select Reset) at any time.

Some data records can be expanded by new data record entries.

Important:

n Changes made in the Configuration Editor will only take effect after restarting HiCAD.

n To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only
create derivations of company-specific configurations. To restore the ISD default settings, the con-
figuration database (HiCAD.cfgdb) must be re-installed.

Change a value in an input field

If you want to change the value of a data record, right-click the corresponding row and select Change. You can
also double-click the row, or press F2, and then overwrite the value.
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Select a value from a listbox

Some settings are selected from a listbox.

Take value from catalogue
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Click the symbol to select a value from the Catalogue Editor. Click the symbol to delete the setting
again.

Select a value by activating/deactivating a checkbox

Some settings can be selected via activation or deactivation of a checkbox. In this example the user has activ-
ated the setting of a symbol (e.g. a diameter symbol) for circular arc dimensions.
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Referenced entries

In the tree structure, derived data records are marked with the symbol. The referenced entry in the right win-
dow is marked with the symbol. If you change a referenced value, the referencing will be removed, and the
changing of the value will have no further effects any more.

Multiple value selection
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Some parameters allow a multiple value selection. Click the icon and select a combination of values from
the displayed list. Click OK to close the list. In the above example the position of an annotation tag for a bore is
specified via a multiple selection.

Collection

If you are asked for a Collection you can select a template file. Click the icon and edit the template files in
the displayed list.

To create your own template files, just copy one of the templates supplied by the ISD and adjust it according to
your individual needs. Save the templates to the HiCAD directory templates/… to enable them to be displayed
in the Configuration Editor.
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Add new data record entry

In some areas you have the options to add new data record entries, or new groups with data record entries. To
do this, click the New group button, enter a name and click OK. The group will then be added and an empty
data record entry will be shown. When you now click on the input fields, you can compose the data record
entry from the values in the displayed selection boxes.
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Permissions
Permissions in the Configuration Editor basically function in the same way as the Windows file system per-
missions. A typical use case is the granting or withdrawing of the permission Change property value - either
for all values (via the context menu of the configuration) or for a sub-tree within the configuration structure,
including all values immediately below (via the context menu of the uppermost item of the sub-tree).

Permissions can be assigned in a User-based or Group-based way. By default, each User (except for the
Administrator) belongs to the Group Everyone. If in the Group Everyone the permission Change property
value is withdrawn, “normal” Users do no longer have the rights to change any values. Changed values in
HiCAD dialogues, too, will then no longer apply if they are stored in the configuration management. It is then
possible to re-assign permissions, e.g. for a particular value or a sub-tree within the configuration structure, to
individual Users. Also, Users can be assigned to other Groups who have different permissions. If a User has

no write permissions for a value, this will be indicated (in an activated User profile) by the icon.

Select Edit > Permissions. The Permissions... dialogue window will be displayed. In the caption of the dia-
logue you will also see the name of the currently selected item in the configuration structure (in the example
below this is the item “Drawing”).

Select the User whose permissions you want to change. Then, specify via the Accept and Deny checkboxes,
which permissions are to be granted to the User. Click the Apply button to apply the current settings without
closing the dialogue window. Select OK to apply the current settings and close the window.

Please note:
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The granted permissions depend, in addition to the selected item in the structure, on the currently act-
ive/selected configuration. For example, it is possible to grant permissions starting from a specific con-
figuration derivation level.

Use Settings in HiCAD
All changes made in the Configuration Editor will take effect after a restart of HiCAD. Certain settings, such as

pre-settings for 2-D dimensioning, can be used in HiCAD immediately after selecting the Reload function
(2-D Dimensioning + Text > Edit > ).

Use the Load parameters function (3-D Dimensioning + Text Tools > Dimensioning > Tools ) to
take over the settings of the BEM3DPAR.DAT file.
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Scenarios
Below you will find some possible scenarios when using the Configuration Management:

n How do I create a user-specific configuration if a use a standalone installation?

n How do I create a user-specific configuration if I work within a network?

n How do I switch between different configurations?

n How do I, as an administrator, assign different rights and settings to various users?

n How do I transfer the settings of a user to the administrator profile?

n I am already a HiCAD user. What effect will an update have on my configuration settings?

n How do I transfer settings from HiCAD 2023 or 2022 to the Configuration database after installing HiCAD
2024 (new installation)?

n Why are suddenly new users added to the configuration management of the configuration database, and
how do I prevent individual users from changing their settings?

n How can I combine locally saved configuration databases with different settings for individual users into
one, central database without losing the settings for the individual users?

n Which settings have priority if administrator settings are different from user settings?

n How do I achieve for several workstations that the administrator profile applies to all users?

n Which options for the changing of settings in the ConfigDB are available in the template files (.csv)?

How do I create a user-specific configuration if a use a standalone
installation?
In this case you are “your own administrator”, so to speak. If you want to change any settings, start the con-
figuration Editor and change the administrator profile.

Important:

Settings which are saved via HiCAD, e.g. 3-D dimensioning settings, will be saved to the profile of the User
who is currently logged onto the operating system, overriding the settings in the administrator profile. If any val-
ues are not available in HiCAD as expected, please check if there are user-specific settings for these values.

How do I create a user-specific configuration if I work within a net-
work?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) and derive a
new configuration. In the User Management, assign the corresponding configuration to the desired User pro-
file. You can also assign the configuration to the main Group of the User. In this way you ensure that all Users
of the same main Group will use this configuration.

Switch to the User profile and edit the required settings.

If no derived configuration is required, you can also simply edit the settings after activation of the User profile in
the base configuration.
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How do I switch between different configurations?
To switch between configurations, select Edit > Activate configuration on the menu bar.

General information on how to activate configurations can be found in the topic User Management.

Please note:

n The permissions assigned here apply globally, i.e. to all Users of the Group.

n Select Edit > Permissions to assign permissions to sub-trees of the configuration. You can then define per-
missions for Users and Groups.

n Use the User Management option to activate configurations for several Users or Groups. Assign the
desired configuration to the Users or Groups.

How do I, as an administrator, assign different rights and settings to
various users?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).

Use the Permission function to assign rights.

Permissions in the Configuration Editor basically function in the same way as the Windows file system per-
missions. A typical use case is the granting or withdrawing of the permission Change property value - either
for all values (via the context menu of the configuration) or for a sub-tree within the configuration structure,
including all values immediately below (via the context menu of the uppermost item of the sub-tree). Per-
missions can be assigned in a User-based or Group-based way.

How do I transfer the settings of a user to the administrator profile?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) .

Select the User Administrator.

Click the icon on the right. The User Management dialogue window will be displayed. In the dialogue, mark the
user whose values you want to apply.
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Click the Adopt values button to transfer the values of the marked user into the active administrator profile.

I am already a HiCAD user. What effect will an update have on my
configuration settings?
When performing an update from e.g. HiCAD 2023, your settings from the existing configuration file
HICAD.CFGDB of your previous HiCAD version will be transferred to the Configuration Management of
HiCAD 2024, namely into the Administrator profile.

When the update is performed, only the values predefined by the ISD, i.e. the “factory settings”, will be
changed. All other (administrator or user) settings will be preserved.

If you use a central configuration database on a server, it will be automatically detected by the update program
by means of the corresponding Registry entry and will be updated. For an update of several workstations, one
single update will be sufficient; a multiple update will, however, not do any harm either (as an already updated
setting will not be updated again).

How do I transfer settings from HiCAD 2023 or 2022 to the Con-
figuration Database when installing HiCAD 2024 (new installation)?
If you perform a (new) installation of HiCAD 2024, the settings predefined by the ISD will be initially used in the
Administrator profile of the Configuration Management. If you want to transfer your individual settings in the file
HICAD.CFGDB from HiCAD 2023 or HiCAD 2022 to the Configuration Management of HiCAD 2024, use the
program CfgDbTool.exe in the HiCAD EXE sub-directory for this.

Furthermore, you are enabled to transfer settings from old DAT and XML files which are now managed in the
Configuration Editor, to the configuration database of Version 2024.

Why are suddenly new users added to the configuration man-
agement of the configuration database, and how do I prevent indi-
vidual users from changing their settings?
If, for example, a user saves the 3-D dimensioning settings via HiCAD, the corresponding user name will be
automatically created in the User Management of the configuration database; the new User will be assigned to
the user Group Everyone by default.
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If you (as Administrator) want to prevent a (new) User from saving his/her individual settings, assign only read
permission to the Group Everyone. When the user now tries to save the settings via HiCAD, a new User will
still be created in the User Management, but the user-specific settings themselves will not be saved. Instead,
the configuration defined by the Administrator continues to apply.

How can I combine locally saved configuration databases with dif-
ferent settings for individual users into one, central database without
losing the settings for the individual users?
Copy the configuration database of a computer to the unlocked server directory. Then, export the active con-
figuration on the other computers and import them to the central database again. Assign, via the User Man-
agement, to each User the corresponding configuration.

On the individual workstations, adjust the Registry entry for the storage location of the database.

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).

Which settings have priority if administrator settings are different
from user settings?
User-specific settings override Administrator settings. Settings in derived configurations override settings in
the superordinate configuration.

Only individual values will be “overridden”: If, for example, an isolated setting contains a User value, this value
will apply to the User. All other settings which have not been changed by the User will be read from the Admin-
istrator profile. The same principle applies to settings in derived configurations: If a setting in a derived con-
figuration contains neither User values nor Administrator values, the superordinate configuration will be
checked etc.

How do I achieve for several workstations that the administrator pro-
file applies to all users?
If the Database is located on the server, nothing more needs to be done. To prevent the settings from being
overridden by user-specific settings that might exist, all User values should be deleted (select the cor-
responding User in the User Management and select Delete values). The User Management will only be active
if you started the Configuration Editor as Administrator.

In case of a local configuration database, use the Configuration Editor to export the settings on the configured
computer (with Administrator profile). In any case it makes sense to remove all user-specific settings that
might still exist.

On all other computers, select File > Import to read in the exported XML file. All user-defined settings that
might still exist should be removed from all computers.

Which options for the changing of settings in the ConfigDB are avail-
able in the template files (.csv)?
The Whitepaper Working with configuration templates is available on this topic.
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Legal notes

© 2024 ISD ® Software und Systeme GmbH. All rights reserved.

This User Guide and the software described herein are provided in conjunction with a license and may only be used or copied in accord-
ance with the terms of the license. The contents of this User Guide solely serve the purpose of information; it may be modified without prior
notice and may not be regarded as binding for the ISD Software und Systeme GmbH. The ISD Software und Systeme GmbH does not
assume any responsibility for the correctness or accuracy of the information provided in this document. No part of this document may be
reproduced, saved to databases or transferred in any other form without prior written permission by the ISD Software und Systeme GmbH,
unless expressly allowed by virtue of the license agreement.

All mentioned products are trademarks or registered trademarks of their respective manufacturers and producers.
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Your local contact

We attach great importance to the direct contact with our
customers and partners, because only a lively dialogue and
constant exchange with practice ensure application- ori-
ented software development.

Feel free to contact us! Whether at our headquarter in Dort-
mund or at one of our branches and subsidiaries in your
vicinity - we will be happy to answer all your questions about
our products and services. We are looking forward to hear-
ing from you!

Headquarter Dortmund

ISD Software und Systeme GmbH

Hauert 4

D-44227 Dortmund

Phone +49 231 9793-0

info@isdgroup.com

ISD locations worldwide at www.isdgroup.com
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