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Adding Own Profiles
Profiles for Profile Installation are listed in tables that are in turn contained in catalogues. Typically, one cata-
logue exists per supplier, which in turn contains further catalogues for different types of profiles. In these cata-
logues you will find one table per profile series, in which the individual profiles are listed. This table must
contain particular columns for the Profile Installation module.

This chapter shows you how to add your own profiles to catalogues in order to use them for the “Profile install-
ation” module.

Adding own profiles
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Sketch-based Profiles
The catalogue entries that are relevant for Profile Installation can be found in the catalogue at Factory stand-
ards > Series > Roof wall facade > Room-closing profiles.

There you will find already some profiles by various manufacturers. You can add your own profiles at User-
defined profiles if desired.

The cross-sections of the profiles have been stored as HiCAD sketches. The relevant chapters explain how
such sketches and the corresponding catalogue entries are created in order to add new profiles.

For this, two steps are required:

n Creation of the sketches and an

n Entry in the catalogue
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Sketches for Sketch-based Profiles
The sketches for the profiles must lie in the XY-plane. When creating the sketch, the currently active coordin-
ate system will be taken over. Therefore, the top view should be active when you create the sketch.

For technical reasons, the mirroring of a profile sketch via 3-D Standard > Transform > Mirror part is not
allowed here. Instead, use the function Sketch > Transform > Mirror GE.

The sketch must contain a closed polyline, which represents the cross-section of the profile to be created. In
particular, an open polyline without thickness is not allowed.

Often,the drawings of profile manufacturers exist in the form of DXF or DWG files. These can be imported to
HiCAD and taken over into a sketch with the functions at Sketch > Derive > Take over edges. When working
with such drawings you should start with applying the function 2-D Geometry > Tools > Sort GE > Entire
drawing. This will clean up smaller technical defects in the drawing such as gaps between the edges.

The upper profile side is aligned to the "front" in the profile installation (if you have activated the Negative dir-
ection checkbox, the alignment will be to the back). "Front" refers to the direction into which the Z-axis of the
coordinate of the sketch used for profile installations points.

The origin of the sketch will become the profile axis when the part is created from it. This axis should be loc-
ated inside the profile, ideally near the centre and on a significant point. If you want to move the origin of the
sketch (and thus the axis of the resulting profile) in a single-part profile, you can use the function Sketch >
New > Processing plane > New origin.

Quality requirements for profile cross-sections
There are some quality requirements with regard to profile cross-sections:

n The cross-sections must not have nay gaps. Otherwise, the profile cannot be created.

n Double line (i.e. two lines on top of each other that appear to be only one line) should be avoided. Other-
wise, various HiCAD functions will not work correctly. To delete double lines, you can use the function
Sketch > Process> Del. > Delete double lines.
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n There must not be any self-intersections within polylines. Otherwise, the profile cannot be created. Inter-
sections of different parts, e.g. of neighbouring profiles or individual elements of multi-part profiles (sand-
wich profile, see below) are not really forbidden, but should be avoided. Otherwise, errors in the
representation may occur, such as disappearing profile edges, or edges that are not displayed correctly.

n To allow tangential edge transitions to be hidden in drawings, "almost tangential" transitions will not be suf-
ficient. You should therefore check whether all of the transitions are actually genuinely tangential. You can
show tangential transitions with the help of a HCM function: To do this, activate the sketch and choose
Sketch > HCM > Coinc. > Automatic positional constraint.

In the dialogue, activate only the Tangential checkbox and the Only connected lines checkbox beneath it.
When you click OK, all tangential transitions will be marked with an icon. If any non-tangential edges are
found, the resulting edges of which are to be "hideable", this can be corrected by means of a tangential
HCM constraint.

n Lines that should actually run exactly horizontally or vertically, but do in fact not fully comply with this
requirement, should be avoided. Sometimes, drawings of manufacturers contain lines that deviate only
minimally (less than 1 degree). In the resulting profiles, this can already lead to an incorrect behaviour of
functions (e.g. subtractions).

n It is desirable that the dimensions specified by the manufacturer are kept to in the drawings. Only in this
way can it be ensured that the dimensions that are applied to the resulting profiles are actually identical
with the dimensions in the drawing.

Also, it is recommended to apply the function Sketch > Tools > Sort GE before saving the sketch. This will
eliminate small errors that can occur while the sketch is drawn.
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Apply sheet thickness and HCM constraints to polyline
If only one polyline without a sheet thickness exists, HiCAD offers various tools to create this sheet thickness.
If the existing polyline is to represent the centre line, you can use the function Sketch > Derive > Offset > izze
> Ableiten > Offset > Offset with end caps.

The entered offset will then be added to both sides of the polyline. So, if you want to apply a sheet thickness of
1 mm, you need to enter an offset of 0.5 here.

If you want to apply the offset only to one side of the polyline, you should use the function Sketch > Derive >
Offset, via point and value. However, the end caps will not be connected in the process. This must be done
manually afterwards. This one-sided offset is particularly recommended for tray panels.

Also, sketch-based profiles offer the option to parameterise the geometry via HCM constraints. For cross-sec-
tions of one-part profiles such as trapezoidal profiles or corrugated profiles, identical basic forms with different
sheet thicknesses are often required. Instead of creating and saving these thicknesses one by one, it is more
convenient to create the sheet thickness as a parameter. These part variables can later be assigned values via
catalogue columns. In this way it is possible to visualize a multitude of geometries by means of only one
sketch.

For this to happen, you need to enter a variables name instead of a numerical value when entering the sheet
thickness or other parameterisable values. This name will then be automatically entered as a part variable.
The part variable can later be assigned a value via a same-named catalogue column.

Here, too, please note that when applying double-sided offsets, the value will be applied to both sides, starting
from the centre line. Therefore, it makes sense to enter, e.g. a value of "THICKNESS/2" for these sketches. In
this way, a thickness of 0.5 mm from the catalogue is applied to both sides of the centre line, resulting in the
desired total thickness of 1 mm.
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Multi-part profiles
For multi-part profiles such as sandwich profiles, one sketch needs to be created for each individual part. the
sketches are grouped in HiCAD with the help of a dummy part, resulting in a structure that looks as follows in
the ICN:

The profile axis is created in the origin of the uppermost dummy part. In contrast to sketches, there is no par-
ticular function for placing of the origin for dummy parts.

However, to determine the position of the origin, you can use the property that the World CS is always used
whenever a dummy part is created. So, to use a particular point on the geometry as the origin of the uppermost
dummy part, you first need to move the entire geometry in such a way that this point coincides with the origin of
the World CS. Then, create a new dummy part.

Other properties
In addition to the geometry, the sketches and the uppermost dummy part can have other properties.

n The Part name for profiles is taken from the catalogue column BZ (Designation), i.e. a manual naming is
not necessary.

n The Article number is used for default settings as the displayed name in the ICN. Since the article number
of the sketch and the uppermost dummy part will e taken over to the resulting profile, the name of the pro-
file should be entered here.
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n For the uppermost part (i.e. depending on the profile type, the uppermost dummy part or the sketch) activ-
ate the BOM-relevance. This property will then be transferred to the resulting profile.

n For the sketches or the uppermost dummy part you should also specify Usages. In the catalogue, there
are already a number of suitable entries. For instance, at Civil Engineering > Profile installation > Ele-
ments you can find R/W trapezoidal profile and R/W panel; at Civil Engineering > Profile installation >
Element parts you can find the usages R/W inner sheet, R/W outer sheet and R/W insulation for sand-
wich profiles. In particular the usage for the elements of sandwich profiles are mandatory, since this inform-
ation is required to apply the insulation material and the inside and outside colours to the corresponding
parts.

n Similar to the usages, you can specify a Part type for sketches or the uppermost dummy part. Here you
use no catalogue entries, but you can enter free texts here. For the most frequent cases special abbre-
viations are available, which can also be automatically translated. These are listed in the table below:

Part type in sketch property Resulting part type in profile

TT(TrapezoidalProfile) Trapezoidal profile

TT(SinusoidalProfile) Sinusoidal profile

TT(LinerTray) Liner tray

TT(SpecialProfile) Room-closing special profile

TT(SandwichPanel) Sandwich panel

TT(SandwichPanelOutsideSheet) Sandwich panel-Outer sheet

TT(SandwichPanelInsideSheet) Sandwich panel-Inner sheet

TT(DWF_clad_insulation_name) Insulation

If these abbreviatons are not used, the TT() is not necessary either! The entering of the part type is not
mandatory when inserting own profiles. So, assign this value only if it is really required.

n No manual entering of Material and Weight for sketches will be necessary - this will be done via the cata-
logue.

n You have the option to create transparent profiles. To do this, place the uppermost part on Layer 40.

Exact and simplified representation
HiCAD offers the option to switch between an exact and a simplified representation. This option is used for sur-
face profiles to switch the representation of the surface structures of profiles on or off. This option can be use-
ful for performance reasons.

To ensure that this switching works properly, one or several parts of the profile cross-must contain sections for
both cases. This is achieved by creating a dummy part (instead of a sketch) which contains two sketches - one
with the name SIMPLE and one with the name EXACT. SIMPLE and EXACT must have been entered for both
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the part name and the article number of the sketch. The simplified and the exact cross-sections will be placed
into these sketches.

All further properties such as Usage and Part type are assigned to the dummy part, so they needn't be entered
twice (once for the SIMPLE and once for EXACT sketch).

Here is an example of a sandwich profile structure, where the Outer sheet and the Inner sheet also contain sim-
plified geometries, but not the Insulation and the Sealing cord:

Insertion point
Profiles often possess visually prominent points, an easy and convenient placing of which on facades would
be desirable, e.g. the middle of the first rib on trapezoidal or sinusoidal profile, or the joint between two sand-
wich profiles. The Profile Installation module enables you to create a situation where it is not the left edge of a
profile, but such a special point that is located in a selected start point of the installation.

For this to happen, first create an isolated point with the function Sketch > New > Point. The point should be
named "1" with the function Sketch > New > Point > Point number. It designates the moving of the profile dur-
ing its creation with the Profile Installation module. The point must be created in the uppermost part - i.e. in the
sketch in case of single-part profiles, or in the dummy part in case of multi-part profiles.

This behaviour can be deactivated in the dialogue. These points will then be ignored, and the start point will be
on the left profile edge instead.
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Save
To save a profile cross-section, the entry for the superordinate dummy part or the sketch must be marked in
the ICN. Right-click the entry and choose Others > Reference part, Save, Detail drawing. In the dialogue win-
dow, choose Save as part.
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The file path should be in the HiCAD installation directory at "…\Kataloge\Werksnormen\Baureihen\Dach Wand
Fassade\Raumabschließende Profile“.

Catalogue entry
The second step required for a creation of own profiles is the creation of a catalogue entry.
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Catalogue Entries for Sketch-based Profiles
Profiles are listed in tables, which are contained in catalogues.

Typically, there is one catalogue per manufacturer, containing further catalogues for the different types of pro-
files. In these catalogues you find one table per profile series, in which the individual profiles are listed.

The following example shows the creation of a new catalogue for SAB profiles.

Use only the name of the manufacturer as the Alias name.
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Now, select the new SAB catalogue. Beneath it, create further catalogues. For the catalogue name, use a com-
bination of the profile designation and the supplier.

After creating the two catalogues, enter a table for a special product:
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Save the created table.

The following categories have be defined beforehand, including the necessary columns for the tables:

n Trapezoidal profile

n Sinusoidal profile
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n Room-closing special profile

n Liner tray

n Sandwich panel

However, you have the option to expand the tables by adding further columns.

Meaning of the columns for Sandwich panels
Column Content Data type

BZ Designation of the profile; is made the Article number of the pro-
file

Text

NAME Path to the part with the sketches (see Step 1), relative to the
Werksnormen (Factory standards) catalogue

Text

THICKNESS_
OUTSIDE

Material thickness, outside (mm) Floating
point num-
ber

THICKNESS_INSIDE Material thickness, inside (mm) Floating
point num-
ber

COVER_WIDTH Installed width (mm) Floating
point num-
ber

CORE_THICKNESS Core thickness (mm) Floating
point num-
ber

CORE_MATERIAL Insulating material; will be applied to the part with the usage
R/W insulation

Text

RIBBING_OUTSIDE Outside ribbing (line pattern) Text

RIBBING_INSIDE Outside ribbing (line pattern) Text

MAX_LENGTH Maximum profile length Integer

MIN_LENGTH Minimum profile length Integer

PACK_MAX_COUNT Maximum number of profiles in one package Integer

PACK_MAX_WEIGHT Maximum weight of onepackage Integer

AREA_WEIGHT Weight referring to the installed width (kg\m²) Floating
point num-
ber

MANUFACTURER Name of manufacturer; can be output in BOMs Text

U-VALUE Thermal transfer coefficient Floating
point num-
ber

SOUND_
INSULATION

Acoustic insulation of the part (dB) Floating
point num-
ber
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Meaning of the columns for single-part profiles
Designation Content Data type

BZ Designation of the profile; is made the Article number of the pro-
file

Text

NAME Path to the part with the sketches (see Step 1), relative to the
Werksnormen (Factory standards) catalogue

Text

THICKNESS Material thickness (mm); controls the sheet thickness in
sketches with HCM constraints

Floating
point num-
ber

COVER_WIDTH Installed width (mm) Floating
point num-
ber

HEIGHT Height (mm) Floating
point num-
ber

SUITABILITY Suitability: 0=Roof, 1=Wall, 2=Roof/Wall, 3=No information Integer

MATERIAL Material, applied to part Text

MAX_LENGTH Maximum profile length Integer

MIN_LENGTH Minimum profile length Integer

PACK_MAX_COUNT Maximum number of profiles in one package Integer

PACK_MAX_WEIGHT Maximum weight of one package Integer

AREA_WEIGHT Weight referring to the installed width (kg\m²) Floating
point num-
ber

MANUFACTURER Name of manufacturer; can be output in BOMs Text

To be able to create a profile, only the columns BZ, NAME, COVER_WIDTH and maybe THICKNESS would
be, theoretically speaking, sufficient. Further entries determining the weight, material, manufacturer or similar,
should, however, also be entered, because otherwise these properties cannot be generated correctly. Some
columns, such as RIBBING_OUTSIDE, U-VALUE will not be used for profile installation and serve only the pur-
pose of providing information in the catalogue.

20 / 26 HiCAD Profile Installation

Catalogue Entries for Sketch-based Profiles



Examples From Practice 

Hardemann: Single skin wall 32 1000 DW
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Kingspan: Double skin roof panels KS1000 FC
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Falk: Double skin wall 1060 WB
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Rechtliche Hinweise:

© 2024 ISD ® Software und Systeme GmbH alle Rechte vorbehalten

Dieses Handbuch sowie die darin beschriebene Software werden unter Lizenz zur Verfügung gestellt und dürfen nur in Übereinstimmung
mit den Lizenzbedingungen verwendet oder kopiert werden. Der Inhalt dieses Handbuches dient ausschließlich zur Information, kann
ohne Vorankündigung verändert werden und ist nicht als Verpflichtung von ISD Software und Systeme GmbH anzusehen. Die ISD Soft-
ware und Systeme GmbH gibt keine Gewähr oder Garantie hinsichtlich der Richtigkeit oder Genauigkeit der Angaben in dieser Dok-
umentation. Kein Teil dieser Dokumentation darf, außer durch das Lizenzabkommen ausdrücklich erlaubt, ohne vorherige, schriftliche
Genehmigung von ISD Software und Systeme GmbH reproduziert, in Datenbanken gespeichert oder in irgendeiner Form übertragen wer-
den.

Alle erwähnten Produkte sind Warenzeichen oder eingetragene Warenzeichen ihrer jeweiligen Hersteller.
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Ihr Ansprechpartner vor Ort

Wir legen großen Wert auf den direkten Kontakt mit
unseren Kunden und Partnern, denn nur ein reger
Dialog und steter Austausch mit der Praxis sorgen
für eine anwendungsgerechte Softwareentwicklung.

Sprechen Sie uns an! Ob in unserer Zentrale in Dort-
mund oder in einer unserer Niederlassungen und
Tochtergesellschaften in Ihrer Nähe – wir stehen
Ihnen gerne für alle Fragen rund um unsere
Produkte und Services zur Verfügung. Wir freuen
uns auf Sie!

Hauptsitz Dortmund

ISD Software und Systeme GmbH

Hauert 4

D-44227 Dortmund

Tel. +49 231 9793-0

info@isdgroup.com

ISD Standorte weltweit unter www.isdgroup.com
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