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Configuration Management

HiCAD offers a central configuration management via the Configuration Editor. This tool allows the creation of cus-
tomer-specific configurations for a wide range of tasks, such as dimensioning, annotation, workshop drawing cre-
ation, fitting of vertical ladders etc. Once adjusted to company-specific requirements, these configurations can
directly be used in HIiCAD, without having to specify any further settings.

The goal of our further developments is a gradual transfer of the previously used system files (*.DAT) with their
adjustable parameter settings into the Configuration Editor, thus enabling a central and safe configuration man-
agement.

You can find an overview of the already transferred DAT files in the topic Transfer of DAT Files to the Configuration
Editor or in the PDF file Key names.pdf.

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link and
select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the PDF file
ISD-Configuration.pdf.

Range of features

= Hijerarchical management of configuration data in the form of module properties

Settings are assigned to modules and sub-modules in a tree-like structure, and represent properties defining the
Behaviour of a module. The categorization facilitates the retrieval of individual settings.

® Central data storage

The configuration data are centrally stored in a database file in a defined location within the user system, which
enables an easy backing up, restoring or copying of data.

®  User-specific data storage

The property definitions are stored separately from the actual user settings. This allows a working in multi-user
environments while eliminating the risk that a user accidentally manipulates the configuration of other users.

= Derived configurations

Configuration Management allows, in addition to the basic configuration supplied by the ISD, the utilisation of
further, derived configurations for a definition of company- and/or team-specific settings. Furthermore, you have
the option to offer to users alternative configurations within one derivation level.

= Central administration of settings via one common graphical Configuration Editor

Eliminates the need for time-consuming and error-prone manipulations in configuration files. The integrated val-
idation of setting values by ranges and selection lists minimizes the risk of incorrect configurations and system
crashes due to invalid values.

= Documentation of settings

Each setting has a multi-language short description and comments on the meaning of the setting values. The
Configuration Editor offers a full text search for property names, descriptions and comments.

= Update-ability of the database

The data storage in the form of user profiles enables an updating of underlying pre-settings, without having to
change existing user settings. Values that have not been changed by the user will automatically be assigned the
updated pre-settings.
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Configuration Management

I Please note that the scope of functions available to you depends on the configuration level of your product, i.e.
not all the functions described in the Help may be available in your product!

The range of selectable modules for a local license depend on the license that was purchased.
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Transfer of DAT Files to the Configuration Editor

As of Version 1700, HIiCAD enables a central configuration management via the Configuration Editor. This tool
allows the creation of customer-specific configurations for a wide range of tasks, such as dimensioning, annotation,
workshop drawing creation, fitting of vertical ladders etc. Once adjusted to company-specific requirements, these
configurations can directly be used in HiICAD, without having to specify any further settings.

The goal of our further developments is a gradual transfer of the previously used system files with their adjustable
parameter settings into the Configuration Editor, thus enabling a central and safe configuration management.

This transfer has already been realised for the following files:
® ALGPAR.DAT (as of 1800.0)
= BEMPAR.DAT (as of 1800.0)
= DIMENSIONING_SETTINGS.XML (as of 1800.0)
= STBEMPAR.DAT (as of 1801.0)
= KRPGEN.DAT (as of 1801.0)
= MASPAR.DAT (as of 1801.1)
® FITTABLE_SETTINGS.XML (as of 1801.0)
m TXTANSI.DAT (as of 1801.1)
= STABMPAR.DAT (as of 1802.0)
= AUBMS3PAR.DAT (as of 1802.0)
® ALG3DPAR.DAT (as of 1901.0)
® SCHRIF.DAT (as of 1901.0)
= TXTFONT.DAT (as of 1901.0)
®= FEATURE.DAT (as of 1901.0)
= LINPAR.DAT (as of 1901.0)
® SSWRITESTEP.DAT (as of 1901.0)
= NORM.DAT (as of 2000.0)
m PASSTAB.DAT (as of 2000.0)
= PASSTABO.DAT (as of 2000.0)
®= ANSGEN.DAT (as of 2100.0)
= PARAMASS.DAT (as of 2101)
m SSTINI3D.DAT (as of 2102)
m SSTINILDAT (as of 2102)
® STB_PARAMETER.DAT (as of 2102)
® GRAPAR.DAT (as of 2201)
= KNTPAR.DAT (as of 2202)
= REF3D_ATTR_AKT.DAT (as of 2300)
m TXTPAR.DAT (as of 2300)
= TABPAR.DAT (as of 2400)
= ABWPAR.DAT (as of 2402)
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algpardatkm.htm
bempardatkm.htm
stbempardatkm.htm
krpgendatkm.htm
maspardatkm.htm
txtansidatkm.htm
stabmpardatkm.htm
aubm3pardatkm.htm
alg3dpardatkm.htm
schrifdatkm.htm
txtfontdatkm.htm
featuredatkm.htm
linpardatkm.htm
sswritestepdatkm.htm
normdatkm.htm
passtabdatkm.htm
passtabdatkm.htm
ansgendatkm.htm
paramassdatkm.htm
sstini3dkm.htm
sstinikm.htm
stbparameterdatkm.htm
grapardatkm.htm
kntpardatkm.htm
ref3d_attr_aktdatkm.htm
txtpardatkm.htm
tabpardatkm.htm
abwpardatkm.htm

Transfer of DAT Files to the Configuration Editor

ABWCOL.DAT (as of 2402)
ABWPOL.DAT (as of 2500)
KRPMOD.DAT (as of 2700)
SKIZZTEC.DAT (as of 2701)

The settings from the files were transferred to the Configuration Editor. The linked lists or the PDF file shows you
where to find the settings from the DAT files in the Configuration Editor (Key names).

Key names.PDF

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link and
select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the PDF file
ISD-Configuration.pdf.
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User Interface

The Configuration Editor enables an editing and managing of configuration. It provides a generic, hierarchical view
of the data and structures contained in the database.

You start the Configuration Editor outside of HICAD, by executing the file ISDCONFIGEDITOR.EXE in the EXE dir-
ectory of HICAD.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

Users without administrator rights and users with administrator rights who did not select the Run as administrator
option upon start:

® |nthe Editor, settings can be edited in the profile of the user who is currently logged on Windows.
® The switching to a different user is not possible. The selection box is greyed out.

Users with administrator rights who have selected the Run as administrator option (right-click and select from con-
text menu) upon start:

®  The administrator profile can be changed in the Editor.

®  The switching to other existing profiles is possible via the selection box, which enables a checking and/or chan-
ging of the configurations of various users.

You can also start the Configuration Editor directly from HiCAD: At the top right corner of the HICAD window, select
Settings > Configuration.

You require administrator rights to start the Configuration Editor!

|4 15D Configuration Editor - HICAD 27.0.0.39 [D:AHICAD.cfgdb] o - [m] x
File Edit View Exiras ISD (1] (7]
®E|F=2a: e (7] e o User |Administrator o
4 [Z] Active configuration (Base configuratior : Description Value Comment
= Drawing | Directory of LVD data CALVD Path where the data required for the bend zone
& Automatic drawing derivation g ! assignment for LVD plants are located
= Modelling Bend angle tolerance o 1 Bend angle tolerance for tocling selection
6 £ Steel Engineering Sheet thickness tolerance 0.25 Sheet thickness tolerance for tooling selection
= Metal Engineering Additional export data
= Profile installation Machines Collection E| Machine list for tooling

= Plant Engineering
4 [ Sheet Metal
=] Sheets with identical cross-sectio
= Default setting
= Sheet development
= Assembling simulation
= Analysis
= Interfaces
= PDM
= Compatibility
5 System settings -
“ | n G
Sheet Metal > Bend zone tooling Q

Customer Mame Customer name

m

The user interface of the Configuration Editor consists of the following areas:
Menu bar

Toolbar

Search function

User selection

Current configuration structure tree

Data record of active configuration

N o o bk~ W=

User Management
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8. Path of the currently selected structure item

9. Version and name of the configuration database

! Important:

Changes in the Configuration Editor will only take effect after you re-start HICAD. Only some particular settings, such
as dimensioning pre-settings, can be applied, via the corresponding HiCAD functions, without a re-start.

Menu Bar

The menu bar of the Configuration Editor contains the following menus:
® File

® Edit

= View

®m Extras

@' Please note:

Some of the function in the menus will only be active when a data record has been selected in the right pane of the
window.

File

Export and import of setting values

The structure and the values of the configuration can be written to a XML file with the Export function. The export
function refers to the currently selected item in the configuration tree. The exported settings can then be imported,
for example, to another configuration database.

Edit
The configuration database administers values on the basis of user-specific setting profiles.

When you select a data record in the tree structure in the left pane of the dialogue window, the corresponding set-
tings will be displayed in the right pane of the window. You can use the functions of the Edit menu to modify these
values and the tree structure.

The changes will take effect after you re-start HICAD.

Function Description

Change If you want to change a value in a data record, activate the desired item and select
Change.
You can also activate the value via double-click or by pressing the F2 key, and then over-
write it.

Changed values, i.e. values deviating from the underlying profile level, are marked appro-
priately and can be reset to the original default value at any time.
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Function Description

Reset This function restores the values in the active directory to the state in the database.

For instance, if you have modified the default settings of the dimensioning rules in various
directories, you can right-click the Usage-dependent entry, choose Reset, and, after con-
firming the security prompt with, restore the modified settings to defaults again. If you con-
firm with Yes, a backup ([Installation directory] > Configuration > HiCAD.cfgdb.[Datel)

will be created, in case you may require the modified settings later again. If you choose
No, the values will be reset without creating a backup.

If you have marked only one value, only this value will be reset.

Copy key Use this function to copy the names of the marked key values in the right window, for
example, to a TXT file.

Rename Use this function to rename derived structures and derived configurations in the tree struc-

ture. The derived structure will be identified by the & icon.

Delete This function deletes only derived structures and derived configurations in the left pane of
the Configuration Editor.

Derive structure Use this function to copy the selected branch in the tree structure and paste it with a dif-
ferent name.

Select reference If a referenced structure has been activated, this function activates the reference.

Activate con- The 2nd level of the tree structure in the left pane of the Configuration Editor consists of

figuration the areas:

= Active configuration and
®  Configurations.

The configuration that you activate with this function will be displayed in the Active con-
figuration area and can then be modified.
Derive con- Use this function to derive an alternative, complete configuration.

figuration Here, too, the same principle as for structure derivation applies: Unchanged settings
inherit their values from the default values (ISD or Administrator profile) of the super-
ordinate configuration.

To edit the derived configuration, select Activate configuration.

Derive Configuration

Derived configurations have a tree-like structure and function according to the same principle as the overlaying of
values in user profiles, i.e. unchanged settings will inherit their values from the default values (ISD or Administrator
profile) of the superordinate configuration. Configurations on the same derivation level are independent from each
other.

To derive configurations, select Edit > Derive configuration. Derived configurations will be displayed in the left pane
of the window, under HiCAD >Configurations. The derivation will be created from the currently active configuration.

To edit a derived configuration, select Edit > Activate configuration. The derived configuration will then be displayed
under HiCAD > Active configuration and can be edited.

' Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only create
derivations of company-specific configurations. To restore the ISD default settings, the configuration database
(HICAD.cfgdb) must be re-installed.
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Derive Structure

Referenced and derived structures generate value inheritance lines. This enables you to create tree units (or indi-
vidual settings) that refer to a reference tree unit and obtain unchanged values initially from the default values of the
reference.

Example: Creation of a new drawing frame for workshop drawings

1. Inthetree structure, select ... > Drawings > Drawing frames > DIN_AOQ. Then select Edit > Derive structure.

]
File Edit View Extras 5D
&2 | fE2R?E (7] User Administrator - |
Fl '_'|HiCAD E Description Value  Comment
4[] Active configuration (Base configuration) Figure name DINAD  must be located as file in HICAD path C:
4 [ Drawing Frame width 179 Dimensions of usable area
= Annotations Frame height 31 Dimensions of usable area

4[5 Drawing frames | | Horizontal distance of insertion point te centre 0
= DIN_AD 763
R DIN_AT |4} Derive structure X
= DN A2 1918 Title block, tables, comments
%DIN_AB Code Drawing.DrawingFrames.DIN_AS Title block, tables, comments
_%DIN:,MH T [[}lN = = 179 Title block, tables, comments
_%DIN_A‘lQ Py = 5.25 Title block, tables, comments

= Views Cancel |

= Automatic drawing derivation

= Modelling | |

= Steel Engineering

3 Metal Engineering

= Profile installation

= Plant Engineering

= Sheet Metal

= Assembling simulation

= Analysis -

Drawing = Drawing frames = DIN_AD

2. Change the displayed key to Drawings.Drawing frames.DIN_AbS.

The structure DIN_AD that will be created now will initially inherit all values from the reference structure DIN_AO.
This means that if one of the default values of DIN_AO will be changed, this value will also change for DIN_AS. The
values of DIN_AD can be assigned new default values. If a default value in the derived structure has been changed,
the value from the reference structure will no longer be inherited, i.e. changes of the corresponding value in the ref-
erence structure will no longer affect the derived value.

Use the Copy values option to take over changed values from a data record that is linked to DIN_AO, e.g. DIN_A3.

' Updates of the reference structure containing new or deleted settings will be adopted by the derived structure.

View

Update

If you change the configuration settings in HICAD while the Configuration Editor is open, the new settings will only be
displayed after activating the Update function.

Example:

When saving the rules set, the rules will be transferred to the Configuration Editor. The rules which are stored there
will be adjusted accordingly, new rules are added, or existing rules are deleted if required. After selecting Update,
the changes will become visible in the Configuration Editor.
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L Please note that HICAD will apply the changes from the configuration management only after restart.

Display key names

HICAD uses the key name to access the settings of the configuration management. The key name is identical in all

languages

A description of this name is displayed in the standard view.

m [3

|4 15D Configuration Editor - HICAD 27.0.0.39 [D:\HICAD.cfgdb] - [m] ped
File Edit | View | Extras ISD
O~ Update F5 @ User [Administrator n
Fl -‘_'|HiCA Display key names [ Description Value Comment
4 HA Show hidden items Dimension lines / Terminations .
43 View mode ’ Defsii calistariine colous 0 Default value for dimension lines + E|
4 projection lines
= Text Line type for dimension lines Line type for dimension lines (0-9)
F———
E Dm:nsonng, 2D = Distance of dimension line to
=] Dimensioning, 3-D Distance of dimension line 8 reference edge or reference point
= Fits table during aligning
& Prafile installation dimension Distance of dimension line for parallel dimensions 10 Dlstalrcledpf dII’T!EHS\DI"I linesin
1 Edge state parallel dimensions
. Switch to outer dirmensioning if
= System triangle Distance for outer dimensicning 8 . -
distance is smaller
3 Plot stamp Dimension line excess length for
= Weld symbols Excess length for ext. dimensiening 1.5 outer dimensions
= Grid annotation Minimum dimension line length 12 Minimum length of dimension line
= Automatic annotation Maximum dimension line length 50 Maximum length of dimension line
-] Coating line in sectional vi
- _Da g i€ in sectionalview Line type for projection lines Line type for projection lines (0-9)
= Drawing frames : S
=V =0 Distance of 2nd projection line
- Iews. ) o Distance 1st projection line 1 from base point, -1: Hide, <-1:
= Automatic drawing derivation - Length of 2nd projection line
< m | » =0: Distance of 2nd projection line =
Drawing.Annetation.Dimensicning2D
_j 150 Configuration Editor - HICAD 27.0.0.38 [D\HICAD.cfgdb] — [m] X
File Edit |View | Extras 15D
- o Update F5 @ User |Administrator n
4 -‘_']HiCA v Display key names L Name Value Description Comment
< HA Show hidden items Dimension lines / Terminations ‘
45 View mode [ |FARDFLIN 0 Dkl vallie Forline color Default value for dimension lines + H
4 projection lines
= Text ISTRART2DF Line type for dimension lines Line type for dimension lines (0-9)
R
B Dm:nsonng,_D = Distance of dimension line to
= Dimensioning3D ABSTDF 8 Distance of dimension line reference edge or reference point
= FitTable during aligning
= DWF Distance of dimension line for parallel Distance of dimension lines in parallel
=] EDGECONDITION BEES0S 10 dimensions dimensions : .
[ SYSTEMTRIANGLE LABWDF k] Distance for outer dimensioning S‘.’wtm to. outer dimensioning if
distance is smaller
IUBLDF 15 Excess length for ext. dimensioning DII’T‘IEI‘IS.IDH I|r1.e excess length for
outer dimensions
BHOZDF 12 Minimum dimension line length Minimum length of dimension line
d AUTOLABELLING RAMADF 50 Mazximum dimension line length Maximum length of dimension line
=] COATINGSYMBOL3D
-l X ISTRARTIDF Line type for projection lines Line type for projection lines (0-9)
= DrawingFrames - —
=i =0 Distance of 2nd projection line
.5 |.ews . ABMIDF 1 Distance 1st projection line from base peint, -1: Hide, <-1: Length
= DrawingGeneration - of 2nd projection line

=0 Distance of 2nd projection line -

Drawing.Annetation.Dimensicning2D

View mode

The view mode enables the precise displaying of changed settings in the Configuration Editor.

Normal

Only

changed val-

ues

All settings will be displayed in the Configuration Editor.

Only changed values of the current user profile, which are marked with the pencil icon ,/’7 will

be displayed.

HiCAD Configuration Management
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Only
changed
default set-
tings

This view mode is only activated if settings in the ISD profile were changed in an update and dif-
fer from the company-specific default settings in the Administrator profile.

The company-specific Administrator profile will be saved in a logl file during an update. After-
wards the changed/new settings will be loaded into the ISD profile. At the end the logl file will
be loaded into the Administrator profile again.

If you load the company-specific Administrator profile after the update and select the Only
changed default settings function only the changed settings will be displayed. The values of
the changed settings stem from the company-specific Administrator profile.

When right-clicking on the value the Reset function can be activated. The setting from the ISD

profile which has been changed in the update will be displayed.

Extras

Language

You can currently select between English and German.

|4 15D Configuration Editor - HICAD 27.0.0.46 [C:\ProgramData\lSD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O x
File Edit View |Extras | ISD
Language Deutsch (Deutschland) User Administrator -
4 .'_"HiCAD Englisch (USA) Value Comment
4 [F] Active co Franzosisch (Frankreich) 05 Clearance width  +
= Drawiing Ungari
garisch (Ungarn) 3
= Automatic drawing derivation (o ——— E' E'
= Modelling GhepEciiliahen) Created new 3
i Steel Engineering Polnisch (Polen) t She;tol\ul\’lnetal parts
- are - | 5
= Metal Engineering relevant.
= Profile installation Condition for
= Plant Engineering Update BOM attributes Always ~ | updating of BOM
4 [F Sheet Metal attributes
= Bend zone tooling T:isffilecor]ltains
e . . the factors for
= Sheets with identical cross-sections the length
[ Default setting Factor file for allowance method ‘R:DIMNGI35.ABW! change to be
= Sheet development taken into
=] Assembling simulation ch?jgntforthe
= Analysis Bendlng
end zones are
= Interfaces Layer number for bend zones 20 displayed on this
= PDM layer.
= Compatibili Flanges are
p g
] System settings Layer number for flanges 10 ;:Iispla)red on this
= : : ayer.
5] Configurations Snme nlder -
Sheet Metal = Default setting

Database directory

For a HiICAD standard installation the database of the Configuration editor will be stored in the HICAD installation dir-

ectory, at .. \Configuration\HiCAD.cfgdb.

The location of the database file will be entered into the Windows Registry at
HKEY_LOCAL_MACHINEASOFTWARE\NSD SOFTWARE UND SYSTEME\HICAD\[VERSION NUMBERNHICAD.CFGD

To change the directory for the file, select Extras > Database directory. If you want to copy the database to the new
location, activate the same-named checkbox.

You can also change the path in HICAD via Settings &~ > Further directories. Before you do so, you need to copy
the database to the new directory.

14/36
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ID | P=IDLibrary  P=ID Symbol Edit  HELIOS FDM e (7
HiCAD Settings - Further directories — O >

| Exit  Settings

i

10 Hicap ID Directories
|':"| g58 Line types Catalogue directory CAHICADKataloge

q - Definitions Cu:un.fiqDB path ChProgramDatahl5D Software und Syste

LogiKal CALOGIEAL

: - Colour combinations
------- Directories

=

Z| Basic settings

----- Steel Engineering

Toolbar
To enable a quick access, some of the functions of the menu bar are also contained in the toolbar:
Vs Change If you want to change a value in a data record, activate the desired item and select
Change.
® Reset This function restores the selected value to the state in the database.
- Update If you change the configuration settings in HICAD while the Configuration Editor is
open, the new settings will only be displayed after activating the Update function.
'f: Collapse all This function collapses the structure display of the Configuration Editor and
shows only the 1st level.
=2 Expand 2 Shows you the first 2 levels of the configuration structure.
levels
=3 Expand 3 | Shows you the first 3 levels of the configuration structure.
levels
E':;; Expand all Expands the complete structure display of the Configuration Editor.

Search Function

The Configuration Editor offers a full text search for value descriptions, comments and setting names. During the pro-
cess, the Editor browses through the structure, beginning (or continuing) at the currently selected node of the con-
figuration tree. Enter the desired search term and click the Find icon.

Frame width | 4

Search for data records

To perform a targeted search for particular entries (e.g. font or font size) in other data records, right-click the desired
data record and select Search value.
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|4 15D Configuration Editor - HICAD 27.0.0.46 [C:\ProgramData\lSD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O x
File Edit View Extras 5D
s g | fzmmiE Rahmen #H @ User Administrator - M|
4 .‘_"HiCAD I Description Value Comment
4[] Active configuration (Base configuration) gt sy -
4 (3 Drawing st dimension line _ .| Type of 1st dimension line termination E|
4 [ Annotations termination, Other d Andern for other dimensions
4 [ Text Height, 1st dimensio D eoes Height of 1st dimension line
= 2-D Font = termination, Other d termination, Other dimensions
= 3-D Font Length, 1st dimensic Wert suchen Length of 1st dimension line
= Dimensioning, 2-D termination, Other d termination for other dimensions

4 [ Dimensioning, 3-D
= Interactive dimensions
4 [ Parametric dimensions
= Font: Dimension figure
= Font: Symbols
= Font: Auxiliary text
= Font: Tolerances
EH HCM dimensions
its table

rofile installation dimensions

Schlissel kopieren
Coelour, 1st dimensio

termination, Other d =i

2nd dimension line
termination, Other
Height, 2nd dimensii
termination, Other d
Length, 2nd dimensi
termination, Other d

Berechtigungen

Celour, 2nd dimensicn line
termination, Other dimensions

[-1: Same as dime.. =

Colour of 1st dimension line
termination, Other dimensions (-1 =
Dimension line colour)

Type of 2nd dimension line termination
for other dimensions

Height of 2nd dimension line
termination, Other dimensions
Length of 2nd dimension line
termination for other dimensions
Colour of 2nd dimensicn line
termination, Other dimensions (-1 =
Dimension line colour)

Dimension line termination,
Base line dimensions
Height, Dimension line
termination. Base line

dge state
ystem triangle
= Plot stamp —

Type of dimension line termination for

Arrowhead, filled v ! . .
base line dimensions

15 Height of dimension line termination, -

Drawing > Annetations > Dimensioning, 3-D > Parametric dimensions

In the search mask you can limit the search to a particular area of the configuration structure tree, by activating the
Limit to checkbox and selecting the area of the configuration structure from the drop down menu.

Find B
Description:  1st dimension line termination, Other dimensions

Yalue: Mone o
[ Lirmit to Parametric dimensions

Find
When you click the Find button, HICAD will jump to the next data record that meets the specified search criteria.

You can change this data record if desired, and continue your search.

User

The configuration database manages values on the basis of user-specific setting profiles. Two pre-defined profiles,
namely ISD and Administrator, have a special function.

User

®

Administrator |'

The ISD profile forms the basis for the settings. In this profile, the HiICAD settings preset by the ISD are contained.

The Administrator profile allows the creation of company-wide default settings deviating from the ISD defaults. In the
process, the Administrator profile constitutes a level overlaying the ISD profile: Unchanged values will be read from
the ISD profile, so that changes of the ISD settings will automatically be transferred to the Administrator profile (and
thus also to the superordinate user profiles) when being updated. Modified, company-specific values will however
be retained.
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Profiles of other users overlay the Administrator profile according to the same principle, with each user profile being
independent of the other user profiles. If setting values are written from HICAD into the database, this process will
always be performed via the profile of the user name currently logged on to Windows. In this way, an accidental
changing of user settings, company-wide settings, or ISD default settings by other users via HiCAD will be pre-
vented.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

®m {Users without administrator rights and users with administrator rights who did not select the Run as admin-
istrator option upon start:

* |nthe Editor, settings can be edited in the profile of the user who is currently logged on Windows.
» The switching to a different user is not possible. The selection box is greyed out.

®  Users with administrator rights who have selected the Run as administrator option (right-click and select from
context menu) upon start:

e The administrator profile can be changed in the Editor.
» The switching to other existing profiles is possible via the selection box, which enables a checking and/or
changing of the configurations of various users.

To edit an entry, double-click a cell in the Value column, or select a cell and press the F2 key, or click the Change
icon on the Toolbar.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately can be reset to the
original default value at any time.

User Management

The integrated User Management allows the creation and deletion of user profiles, as well as the deletion or the tak-
ing over of user-specific values into other user profiles. In this way, for example, an Administrator is enabled to spe-
cify settings via HICAD managed in the Configuration Editor. These are initially saved in his/her Windows user
profile, and can later be taken over to the administrator profile as company defaults, and will then apply to all users.
Click the " icon to call the User Management. The dialogue window is composed of the following tabs:

m Settings

= User

B Groups

X
Click the . icon to close the dialogue window.

! Important:

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started.
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Settings

|4 User Management et

Settings | User | Groups

Same configuration for all users

If you use a central configuration database the the settings saved in the configuration
database will have effect on all HICAD users. The last saved settings apply to all users,

A change of this setting requires a re-start of all applications using the configuration
database,

Apply and restart Editor

Activate the Same configuration for all users checkbox to switch off the User Management and the Permissions
Management. The settings will then always be written to the Administrator profile.

The User Management is by default deactivated when the configuration database is installed for the first time.

User
_ﬁ User Managerment =
Settings | User | Groups
M Acti figurati G [ t
ame ive configuration roup assignmen [ Add ]
008 | Same as main group = | 10002, 2_0002
R
023 [Sameas main group v] 2_0002 [ Sl ]
P ) [ e
Admini !
e _ﬁ Group assignment for Users: 023 et _]
t
[C] Everyone a
[C] 1_0001
1_0002
-t T
[C] 2_0001
2_0002 [ Cancel |
[C] Administrators B
| ——
User tab
Add Adds a new User to the table.
18/36
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User tab
Rename
Delete

Group assign-
ment

Adopt values
Delete values

Table column:

Active con-
figuration

g” Please note:

Enables you to change a selected User name.
Deletes the selected User without any further confirmation prompt.

The user rights are controlled via group assignments. A User can belong to several
Groups. Use the Group assignment button to select Groups for Users. The main Group of
the User will be highlighted if you mark this Group and then click the As default button.
The main Group will be available during the configuration selection of the User. Click OK
to exit the Group selection.

Use this function to apply the values of a selected User to the active User.

Deletes the changed values of the selected User, thus restoring the values to that of the
administrator profile / the values preset by the ISD.

The Configuration Editor allows the creation of different user configurations via the Derive
configuration function. One of these configurations and the Base configuration can be
assigned to the User in the Active configuration column.

HICAD will use the Windows Login name in case of an utilisation via HiCAD, i.e. these names need to match when

users are created.
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Groups
|4 User Management et
M Acti fi ti
ame Ive configuration [ Add

Everyone [Ease configuration = ]

1_0001 [Ease configuration = ]

1_0002 [Base canfiguration ot ]

2_0001 [Ease configuration - ]

2_0002 [Ease configuration = ]

Administrators [Ease configuration = ]

Permissions for: Everyone

Change property value

[[] Activate configuration

[C] Derive configuration

[[] Rename configuration

[C] Delete configuration

[C] Derive structure

[[] Delete derived structure

[T] Rename derived structu

[C] Change derived texts

[[] Change permissions
Group tab
Add Adds a new Group to the table.
Rename Enables you to change a selected Group name.
Delete Deletes the selected Group without any further confirmation prompt.
Table column: The Configuration Editor allows the creation of different user configurations via the Derive
Active con- configuration function. One of these configurations and the Base configuration can be
figuration assigned to the Group in the Active configuration column.
Permissions for: The rights of a Group can be specified in the Permissions for: ... area, by activating the

e.g. Designers A corresponding checkboxes. If a User belongs to several Groups, the activated rights of

these additional Groups are also available to him/her.

The permissions enable you to specify, for example, that a User can only read the settings
defined by the administrator, but not define and save his/her own settings, thus ensuring
company-wide, identical settings.

@ Please note:
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® The permissions that are assigned here apply globally, i.e. for all Users of the Group.

®m Use the Permissions function if you want to assign permissions for sub-trees of the configuration. You can then
define permissions for Users and Groups .

Configuration Structure
The left pane of the Configuration Editor dialogue window contains the following entries (below HiCAD):
m Active Configuration and

®  Configurations.

| 1SD Configuration Editor - HICAD 27.0.0.46 [C:\ProgramData\lISD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O *
File Edit View Extras 5D
[} (7} User Administrator -
4 .'_"HiCAD Description Value  Comment
4[] Active configuration (Base configuration)

= Drawing

= Automatic drawing derivation

= Modelling

= Steel Engineering
= Metal Engineering
= Profile installation
= Plant Engineering
= Sheet Metal
= Assembling simulation
= Analysis
= Interfaces
= PDM
= Compatibility
= System settings
4 [E] Configurations
4 [Z] Base configuration
] 003_001_001
5] 003_001_002
] 003_001_003

Under Active configuration you will find the current HiCAD settings.

Under Configurations you can find the base configuration and all derived configurations of the active user. Use the
Derive configuration function to load data into the Active configuration area. There, you can activate individual data
records and edit them in the right pane of the dialogue window.

] Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only create
derivations of company-specific configurations. To restore the ISD default settings, the configuration database
(HICAD.cfgdb) must be re-installed.

Data Record

In the right pane of the Configurator Editor you can edit the data records that you activate in the left pane of the win-
dow. The data record consists of the Description, the Value and the Comment. When you display the key name via
View > Display key names, the system name of the entry will be additionally displayed.

You define your individual profile for HICAD via the setting of values. The values are not always numerical values.
They may also be:

® 3 unit of measurement (mm, cm, ...)

® 3 string ("Collection”)
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® 3 key name

® 3 freeentry

® 3 checkmark (e.g. to activate the display of a query etc.)

® 3 procedure (Always, Dependent on dimension plane, etc.)
® an entry from the Catalogue Editor

® 3 selection of attributes.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately and can be reset to
the original default value (right-click and select Reset) at any time.

Some data records can be expanded by new data record entries.

! Important:
®  Changes made in the Configuration Editor will only take effect after restarting HiCAD.

®  To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only cre-
ate derivations of company-specific configurations. To restore the ISD default settings, the configuration data-
base (HICAD.cfgdb) must be re-installed.

Change a value in an input field

|4 15D Configuration Editer - HICAD 27.0.0.46 [C:\ProgramData\ISD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O >
File Edit View Extras [SD
V4 g ?] =233 E‘E L7] User |atesner
4 .‘_"HiCAD -l Description Value Comment
4[] Active configuration (Base configuratior For HICAD fonts: 1,2,3,... For
4 [ Drawing SnRGbES il TrueType fonts: T1, T2, T3,...
4 [ Annotations Colour 5 @ Dunkelblau ~ | Font colour
4 [ Text Size 3 [
- ndern
& 2-D Font = Layer 1
= 3-D Font nof
& Dirnensioning, 2-D Orientation Bottom, g
— ’ Wert suchen .
=] Dimensicning, 3-D ratic and
= Fits table Font 1 Schliissel kopieren
= Profile installation dimension ||

= Edge state

= System triangle
= Plot stamp

E Weld symbols
= Grid annotation

= Automatic annotation Berechtigungen

= Coating line in sectional view

= Drawing frames -

| m | »

Drawing > Annetations » Text = 2-D Font

If you want to change the value of a data record, right-click the corresponding row and select Change. You can also
double-click the row, or press F2, and then overwrite the value.
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Select a value from a listhox

|4 1SD Configuration Editor - HICAD 27.0.0.46 [C\ProgramData\ISD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O X
File Edit View Extras 5D
7 e o) ?E% @ User |atesner
Fl -.‘_‘|HiCAD = Description Value Comment
4[] Active configuration (Base configuratior Font b T1 For HIiCAD fonts: 1,2,3,... For
4 [F Drawing ot number TrueType fonts: T1, T2, T3,...
- Annotations Colour S Dunkelblau ~ | Font colour
4 = Size ' g “ Int size
[ 2-D Font L 5 [ Dunkelblau | |
= £ Layer 6 :] Orange nt layer
(£3-D Font . . 7 O o = [kt alignment: Position of
[Z Dimensioning, 2-D RERiaton ’ i | [ertion point
Dimensioning, 3-D . - . nt selection (aspect ratio and
3 Fits table Font % :] Orange Iination_angle}
= Profile installation dimension | 10: :] Dunkelbraun ly for HICAD fonts
= Edge state 1 - Dunkelgrin
1 System triangle . - .
3 13 - Blau
» [E Weld symbols 14 :] Dunkelorange
3 Grid annotation 15 :] G.rau
1 Automatic annotation 16 (I Lis
[ Coating line in sectional view . - Blaugriin
¢ [ Drawing frames . 13 :] Zosa B
d raugrun
4 m 3
l - - l 200 [ ] weiB
Drawing » Annotations » Text = 2-D Font 21. @ Griin
Some settings are selected from a listbox.
| I8 150 HiCAD 27, CAD CAD — O b4
File Edit View Extras [SD
V4 [+ ?E% @ User Administrator ]
F] -.]_'|HiCAD Description Value Comment
4[] Active configuration (Base configuration) Clearance 05 Clearance width
¢ = Drawing .
Automatic drawing derivation ]
Modelling B Allgemeine Baustahle X Created new L
Steel Engineering _I Sheet Metal parts | =
: v () | Al | are BOM-
Metal Engineering e relevant.
Profile installation B"Q Er i (6 [ = Condition for
. . =] Stahle =
¢ Plant Engineering Q b 105104C L0711 ways ¥ | updating of BOM
4 [ Sheet Metal b 1051040 £044 b attributes
[=] Bend zone tooling b 1051045R L0711 This file contains
[ Sheets with identical b 15510+C 1.0710 the factors for
e P 155104 1.0710 the length
Default setting Nerar st b 1551045R 10710 INGG35.ABW! change to be
Sheet development @ b i } 185104C 1.0712 taken into
- ufieisen
(5 Assembling simulation Q NE-Metalle P 18510+N 1.0712 accngntforthe
Analysis 5 b 1851045R 1.0712 bending
I : S EdEImhlfefe P 25CrMod+C 17218 end e
| e Q ke g displayed on this
. Z1PDM b 25CrMo4HC 17218 layer.
- P 26Mn5+C 11161
Compatibility Q i b 25MNSHC B Flanges are
inarten n L - -
displayed on this
S?rstem.settlﬂgs Q Anhang b 26Mo2+C 1.5417 Ia).rsr.)‘r
Configurations @ Anwender Werkstoffe b 26Mo2+LC 1.5417 Some older
b 375104C 1.0713 N functions still
P 375104 1.0713 require this
< > | b 3751045R 1.0713 w parameter.
: | p—— . | Representation of =
Sheet Metal > Default setting [ ] [ ghiecien ] i

Click the symbol to select a value from the Catalogue Editor. Click the symbol to delete the setting again.
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Select a value by activating/deactivating of a checkbox

= Grid annotation

= Automatic annotation

= Coating line in sectional view
= Drawing frames
= Views

= Automatic drawing derivation

“ m | »

Reference systemn for circle dimensioning

Circle dimension
Dimensicn orientation
Free

Position of angular dimensien

Z-dimensioning for correction [

Indirect

Automatic

Direction of dimensioning (0-1: Parallel to
lines, 2-5: Axially parallel)

|4 1SD Configuration Editor - HICAD 27.0.0.46 [C\ProgramData\ISD Software und Systeme\HiCAD 2022\HiCAD.cfgdb] — O X
File Edit View Extras 5D
Vs g ? 2= 8: 7] User |atesner
Fl -‘_‘|HiCAD = Description Value Comment
4 [ Acti figuration (B figurati —
B - Iie configuishon (Ese conhaysciion Position of 2nd dimensioning symbel relative
4 [ Drawing Position (right), 2nd dimensioning symbol -1 to dimension figure, parallel to dimension
4 [ Annotations line
A Text Position (superscript), 2nd dimensioning 0 P05|_t|on m.c an_ dlmensm_mng syr_'ﬂbol r.elatn.re
= Dimensioning, 2-D to dimension figure, vertical to dimension
9. E symbol line
= Dimensioning, 3-D 1 oy ol pa i bol (0-39)
— - symbol combination of symbol (0-99),
= FltSFEbFE . ] 1st symbol combination 0 underline, auxiliary text, text delimiter (0-9)
= Profile installation dimension o b ik o 2nd symbol combination of symbol (0-99),
= Edge state L A S underline, auxiliary text, text delimiter (0-3)
= System triangle Set symbol for arc dimension Set diameter symbol or ra:ilus symbol for
= Plot stamp — circular arc dimensioning?
= Weld symbols Others

~ | Reference system for circle dimensioning

~ | Dimension type for Circle dimension

Position of angular dimension between or
outside the selected legs

Allow Z-dimensicning for correction

Drawing = Annetations > Dimensioning, 2-D

Some settings can be selected via activation or deactivation of a checkbox. In this example the user has activated

the setting of a symbol (e.g. a diameter symbol) for circular arc dimensions.

Referenced entries

File Edit View Extras [SD

| 1SD Configuration Editor - HICAD 27.0.0.46 [C:\ProgramData\ISD Software und Systeme\HICAD 2022\HICAD.cfgdb)

Ve 2| f==2E (7] User |atesner
4 -‘_'|HiCAD - Description Value  Comment
4 [ Active configuration (Base configuratior ‘=2 Figure name DINAT - must be located as file in HICAD path C:
4 [ Drawing == Frame width 831 Dimensions of usable area
51 Annetations =2 Frame height 584 Dimensions of usable area
4 [ Drawing frames =2 Horizontal distance of insertion point to centre 0
=1 DIN_AD =2 Vertical distance of insertion peint to centre 27.63
%g::‘ﬁl = &2 ¥-minimum of locked area B43.8 Title block, tables, comments
_%DIN_AB &2 Y-minimum of locked area 0 Title block, tables, comments
_%DIN:,MH =2 X-maximum of locked area 831 Title block, tables, comments
S DIN_A4Q & Y-maximum of locked area 55.25 Title block, tables, comments
= Views
= Automatic drawing derivation
= Modelling L4
Steel Engineering
etal Engineering
= Profile installation
lant Engineering
= Sheet Metal -
“ m 3

Drawing > Drawing frames > DIN_A1

In the tree structure, derived data records are marked with the &) symbol. The referenced entry in the right window
is marked with the &= symbol. If you change a referenced value, the referencing will be removed, and the changing
of the value will have no further effects any more.
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Multiple value selection

File Edit View Extras 5D
SR | feRrmE

_j 5D Configuration Editor - HICAD 27.0.0.46 [C:\Progra

User |atesner

4 [9HicAD
4 ] Active configuration (Base configuration)
Drawing
4 [ Automatic drawing derivation
4 [ Production drawing
¢ = Drawing

rawing frames
nnotations

evelopment

sage assignment

= Usage-dependent
4 [F Template
=] Drawing frames
= Annotation
= View group
H Views

Description

Show system axes

Annotate bores
Annotate main parts
Annotate boltings
Annotate Standard Parts
Annotate sub-parts

Annotate weld seams

Value Comment

fom—— Create system axis annotations in views of

@ in views of the type
(A . ... . o

@ feam front wviews of the type
Left

El

arts in views of the type

Right ;
Fri n views of the type
= Back i ‘
T 5 in views of type
! Bottom i P
AYO landscape
AXO portrait

Sectional view left

Sectional view right

ok || cancel

= View type assignment, Parts
=] View type assignment, General
= View type assignment, Part environ _

Automatic drawing derivation > Production drawing > Usage-dependent > Template > View type assignment, General

Some parameters allow a multiple value selection. Click the J icon and select a combination of values from the dis-
played list. Click OK to close the list. In the above example the position of an annotation tag for a bore is specified via

a multiple selection.

Collection
_ﬁ?:i_: atio or - HICAD 27.0.0.46 [C:\Pro
File Edit View Extras 5D
/08 23z

User |atesner

[ Start configuration
[H Directories

= Load/Save

& Data save

¢ [ Identification

[ Referencing

- Annotations
I Text
[= Dimensioning, 2-D
I (= Dimensioning, 3-D
HCM symbol
[ Annotation tags
4 [ Calculations
[=] Radial pin calculation

[= Cylindrical pin calculation i
[ Graphic
¢ [ Visualisation
[ Feature
& 2-D Lines -

Description Value

List of Excel report templates

Collection E]

Comment

String Collection Editor

Enter the strings in the collection (one per ling):

RadialPinCalculation_detailed xitx
Radialstiftberechnung_detailiert xftx

0K | Cancel |

2

| System settings > Calculations > Radial pin calculation
St oa e s e 5

If you are asked for a Collection you can select a template file. Click the J icon and edit the template files in the dis-
played list.
To create your own template files, just copy one of the templates supplied by the ISD and adjust it according to your

individual needs. Save the templates to the HICAD directory templates/... to enable them to be displayed in the Con-
figuration Editor.
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HICAD CAD — O X
2 (7] User Administrator o 'B
Fl -.‘_'|HiCAD © | Usage Part type Usage-dependent setting
4[] Active configuration (Base configuration) LALSSE il RN -
= Drawing Post All POST
4 [ Automatic drawing derivation Post profile All DEFAULT(STAHLROHRE)
4 [ Production drawing Railing All RAILING
= Drawing Railing segment All RAILINGSEGMENT
1 Drawing frames Rod All DEFAULT{STAHLROHRE)
1 Annotations Skirting board All STRINGER
= Development | 1SD Configuration Editor - HICAD 27.0.0.46 [C:\Pro... X |DEFAULT(FLACHSTAHL)
1 Usage assignment =
I+ [E Usage-dependent Group
i drowi DEFAULT(KANTBLECHE)
j Mj d E.untmg rawing 003 po1_0o1 MC_PROFILE
=1 Modelling
DEFAULT
Steel Engineering
7 Metal Engineering TrerTT 3, T DEFAULT
Profile installation Eternit panel All DEFAULT(KAMTBLECHE)
Plant Engineering R/W panel All ISD_RW_PAMEL
= Sheet Metal R/W trapezoidal profile All ISD_RW_TRAPEZPROFILE(ASSEMBLY)
Assembling simulation Roof/Wall Al RW_GROUP
= Analysis Sheet Metal
= Interfaces All Sheet Metal DEFAULT(KAMTBLECHE)
QN Stairs
Compatibility i
e I
b Configurations =
Automatic drawing derivation > Production drawing > Usage assignment

In some areas you have the options to add new data record entries, or new groups with data record entries. To do
this, click the New group button, enter a name and click OK. The group will then be added and an empty data
record entry will be shown. When you now click on the input fields, you can compose the data record entry from the

values in the displayed selection boxes.

| 1SD Configuration Editor - HICAD 27.0.0.46 [C:\ProgramData\lS|

4[5 Automnatic drawing derivation
4 [ Production drawing
1 Drawing

I (= Drawing frames
I [ Annotations

Development

Usage assignment

1 Usage-dependent

¢ [E Mounting drawing
¢ Modelling

Steel Engineering
Metal Engineering
Profile installation
Plant Engineering
Sheet Metal

= Assembling simulation
Analysis

Interfaces

PDM

Compatibility

System settings

Configurations

General
File Edit View Extras ISD All
Al Catalogue
(=
- Columns
4 [MHicAD || il Engineering » General » Colurn
4[] Active configuration (Base configuration) Girder
Civil Enginesring > General » Girder
ALUCOBOND tray panel

Civil Engineering > Element installation > ALUCOBOND > Tray panels
ALUCOBOND profile

Civil Engineering > Element instolligtion > ALUCOBOND > Tray panels
ALUCOBOND composite panel

Civil Engineering > Element installgtion > ALUCOBOND > Tray panels
Eternit assembly

Civil Engineering > Elament installation > Erermir > Tray panels
Eternit panel

Civil Engineering » Flement installation » Eternit > Tray porels
Sub-structure

Civil Engineering > Element installation > Sub-structure

Contact profile
Civil Engineering > Metal Engingering » Elements = Contoct profile

m

Cover tray

Civil Engineering > Metal Engineering > Elements > Cover tray
Seal

Civil Enginesring » Metal Engineering > Elements » Seal
Inserted profile

Ciwvil Engineering » Metal Engineering > Elements » Inserted profile
Isolatar

Civil Enginesring > Metal Enginsering » Elements » lsolztor

Support profile
Civil Engineening > Metal Engineering > Elements » Support profiles

= User Administrator

sage-dependent setting
EFAULT(FLACHSTAHL) -
EFAULT(FLUTZ_PROFILE_281)
EFAULT(GITTERROSTE)
EFAULT(HOHLPROFILE)
EFAULT(I_PROFILE)
EFAULT(KRANSCHIEMEN)
EFAULT(L_PROFILE)
EFAULT(PROFILE)
EFAULT(STAHLROHRE)
EFAULT(SECHSKANTSTAHL)
EFAULT(STAHLROHRE)
EFAULT(T_PROFILE)
EFAULT(U_PROFILE)
EFAULT(U_PROFILE_KALT)
EFAULT(VIERKANTSTAHL)
EFAULT(Z_PROFILE)

EFALLT

[ Mew ][ Delete ][ Mew group

Automatic drawing derivation > Production drawing > Usage assignment
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Permissions

Permissions in the Configuration Editor basically function in the same way as the Windows file system permissions.
A typical use case is the granting or withdrawing of the permission Change property value - either for all values (via
the context menu of the configuration) or for a sub-tree within the configuration structure, including all values imme-
diately below (via the context menu of the uppermost item of the sub-tree).

Permissions can be assigned in a User-based or Group-based way. By default, each User (except for the Admin-
istrator) belongs to the Group Everyone. If in the Group Everyone the permission Change property value is with-
drawn, “normal” Users do no longer have the rights to change any values. Changed values in HiCAD dialogues, too,
will then no longer apply if they are stored in the configuration management. It is then possible to re-assign per-
missions, e.g. for a particular value or a sub-tree within the configuration structure, to individual Users. Also, Users
can be assigned to other Groups who have different permissions. If a User has no write permissions for a value, this

will be indicated (in an activated User profile) by the % icon.

Select Edit > Permissions. The Permissions... dialogue window will be displayed. In the caption of the dialogue you
will also see the name of the currently selected item in the configuration structure (in the example below this is the
item “Drawing”).

|4 Permissions - Drawing et
Mame Type [ oK l

002 User

023 User [ Cancel l

Everyone Group

1.0001 Group [ Apply l

1_0002 Group

2_0001 Group

2_0002 Group

Permissions for: 008

Permission Accept Deny
Change property value
Derive structure
Delete derived structure
Rename derived structure

Change derived texts

OOoOEOOME
OOoOO0O«EOO

Change permissions

Select the User whose permissions you want to change. Then, specify via the Accept and Deny checkboxes, which
permissions are to be granted to the User. Click the Apply button to apply the current settings without closing the dia-
logue window. Select OK to apply the current settings and close the window.

@ Please note:

The granted permissions depend, in addition to the selected item in the structure, on the currently active/selected
configuration. For exampile, it is possible to grant permissions starting from a specific configuration derivation level.
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Use Settings in HICAD

All changes made in the Configuration Editor will take effect after a restart of HICAD. Certain settings, such as pre-

|
settings for 2-D dimensioning, can be used in HICAD immediately after selecting the Reload I Ifunction (2-D

Dimensioning + Text > Edit> 7 ).

-

Use the Load parameters = El function (3-D Dimensioning + Text Tools > Dimensioning > Tools ) to take over

the settings of the BEM3DPAR.DAT file.
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Scenarios

Below you will find some possible scenarios when using the Configuration Management:

® How do | create a user-specific configuration if a use a standalone installation?

® How do | create a user-specific configuration if | work within a network?

® How do | switch between different configurations?

® Howdo |, as an administrator, assign different rights and settings to various users?

= How do | transfer the settings of a user to the administrator profile?

® | am already a HiCAD user. What effect will an update have on my configuration settings?

® How do | transfer settings from HICAD 2021 or 2020 to the Configuration database after installing HICAD 2022
(new installation)?

® Why are suddenly new users added to the configuration management of the configuration database, and how do
| prevent individual users from changing their settings?

® How can | combine locally saved configuration databases with different settings for individual users into one,
central database without losing the settings for the individual users?

®  Which settings have priority if administrator settings are different from user settings?
® How do | achieve for several workstations that the administrator profile applies to all users?

® Which options for the changing of settings in the ConfigDB are available in the template files (.csv)?

How do | create a user-specific configuration if a use a standalone installation?

In this case you are “your own administrator”, so to speak. If you want to change any settings, start the configuration
Editor and change the administrator profile.

I Important:

Settings which are saved via HiCAD, e.g. 3-D dimensioning settings, will be saved to the profile of the User who is
currently logged onto the operating system, overriding the settings in the administrator profile. If any values are not
available in HICAD as expected, please check if there are user-specific settings for these values.

How do | create a user-specific configuration if | work within a network?

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) and derive a new
configuration. In the User Management, assign the corresponding configuration to the desired User profile. You can
also assign the configuration to the main Group of the User. In this way you ensure that all Users of the same main
Group will use this configuration.

Switch to the User profile and edit the required settings.

If no derived configuration is required, you can also simply edit the settings after activation of the User profile in the
base configuration.

How do | switch between different configurations?

To switch between configurations, select Edit > Activate configuration on the menu bar.
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General information on how to activate configurations can be found in the topic User Management.

@ Please note:

® The permissions assigned here apply globally, i.e. to all Users of the Group.

® Select Edit > Permissions to assign permissions to sub-trees of the configuration. You can then define per-
missions for Users and Groups.

® Use the User Management option to activate configurations for several Users or Groups. Assign the desired con-
figuration to the Users or Groups.

How do |, as an administrator, assign different rights and settings to various users?

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).
Use the Permission function to assign rights.

Permissions in the Configuration Editor basically function in the same way as the Windows file system permissions.
A typical use case is the granting or withdrawing of the permission Change property value - either for all values (via
the context menu of the configuration) or for a sub-tree within the configuration structure, including all values imme-
diately below (via the context menu of the uppermost item of the sub-tree). Permissions can be assigned in a User-
based or Group-based way.

How do | transfer the settings of a user to the administrator profile?

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) .

Select the User Administrator.

Adrministrator |* |

150 l

Administrator

023 12

03z

Click the icon on the right. The User Management dialogue window will be displayed. In the dialogue, mark the user
whose values you want to apply.
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| User Management 4
User | Groups
Mame Active configuration Group assignment [ Add ]
008 [SEme as rnain group v] 1_0002, 2_0002
023 [SEmE as main group v] 2_0002 [ Renaime ]
088 | Same as main group = | 2.0001, 1_0002 [ Delete ]
Administrator [SEme as main group v] Administrators [ Group assignment ]
[ Adopt values ]
[ Delete values ]

Click the Adopt values button to transfer the values of the marked user into the active administrator profile.

| am already a HiCAD user. What effect will an update have on my configuration set-
tings?

When performing an update from HiCAD 2021 or HiCAD 2020, your settings from the existing configuration file
HICAD.CFGDB of your previous HiCAD version will be transferred to the Configuration Management of HICAD 2022,
namely into the Administrator profile.

When the update is performed, only the values predefined by the ISD, i.e. the “factory settings”, will be changed. All
other (administrator or user) settings will be preserved.

If you use a central configuration database on a server, it will be automatically detected by the update program by
means of the corresponding Registry entry and will be updated. For an update of several workstations, one single
update will be sufficient; a multiple update will, however, not do any harm either (as an already updated setting will
not be updated again).

How do | transfer settings from HiCAD 2021 or 2020 to the Configuration Database
when installing HiCAD 2022 (new installation)?

If you perform a (new) installation of HICAD 2022, the settings predefined by the ISD will be initially used in the
Administrator profile of the Configuration Management. If you want to transfer your individual settings in the file
HICAD.CFGDB from HICAD 2021 or HICAD 2020 to the Configuration Management of HICAD 2022, use the pro-
gram CfgDbTool.exe in the HICAD EXE sub-directory for this.

Furthermore, you are enabled to transfer settings from old DAT and XML files which are now managed in the Con-
figuration Editor, to the configuration database of Version 2022.

Proceed as follows:
1. Start the CfgDbTool.exe program in the HICAD EXE sub-directory.

Use the Update tab of the CfgDBTool you tab to transfer the settings of your previous configuration file (.CFDB) to
the configuration file of Version 2022.
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1% CfgDbTool — O %
Update | Migrate
Installed database |CAHICAD20200Configuration\HICAD. cfgdb |I|
Update source CAHICAD 2022 Configuration\HiCAD.cfgdb IZI
Update target ChProgramDatat|50 Software und SystemeHICAD 2022\HICAL |I|

Update
2. Select the directories.
Update tab
Installed The configuration database to be updated, i.e. (the previous configuration database of
database HIiCAD).
Update The configuration database of the new version; the configuration database with the current
source ISD settings can be found in the folder: [HICAD installation directory\Configuration.
Update tar- The result of the update. If you enter the same file here as in the Installed database, a backup
get of the previous configuration database will be created. You cannot enter the same database

here that you entered in the Update source field.

3. Click the Update button to start the process.

Use the Migrate tab to transfer your individual settings from old DAT and XML files which are now managed in the
Configuration Editor, to the configuration database of Version 2022.

The setting files with their adjustments need to be copied to the HICAD SYS subdirectory of the new HiCAD version
for this purpose.

1. Start the CfgDbTool.exe program in the HiICAD EXE sub-directory and activate the Migrate tab.

|4 CfgDbTool — O *

Update | Migrate

Base folder CAHICAD2020 III
Target database Ch\ProgramDatat |50 Software und Systerme\HICAD 20220HICAD. ¢ III

Pararmeter files must be available in sub folders with the same names like in a
HICAD installation (e.g. sys folder) and under their criginal names.

Migrate

2. Select the directories.
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Migrate tab

Base folder Here you enter the directory where your old DAT and XML files etc. are located. Please make
sure that the old files have the same name and are located in the same directory structure as
in a HICAD standard installation.

Target data- Here you specify the database to which the data are to be transferred.

base

3. Click the Migrate button to start the process.

Why are suddenly new users added to the configuration management of the con-
figuration database, and how do | prevent individual users from changing their set-
tings?

If, for example, a user saves the 3-D dimensioning settings via HiCAD, the corresponding user name will be auto-
matically created in the User Management of the configuration database; the new User will be assigned to the user
Group Everyone by default.

If you (as Administrator) want to prevent a (new) User from saving his/her individual settings, assign only read per-
mission to the Group Everyone. When the user now tries to save the settings via HiCAD, a new User will still be cre-
ated in the User Management, but the user-specific settings themselves will not be saved. Instead, the configuration
defined by the Administrator continues to apply.

How can | combine locally saved configuration databases with different settings for
individual users into one, central database without losing the settings for the indi-
vidual users?

Copy the configuration database of a computer to the unlocked server directory. Then, export the active con-
figuration on the other computers and import them to the central database again. Assign, via the User Management,
to each User the corresponding configuration.

On the individual workstations, adjust the Registry entry for the storage location of the database.

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).
Which settings have priority if administrator settings are different from user settings?

User-specific settings override Administrator settings. Settings in derived configurations override settings in the
superordinate configuration.

Only individual values will be “overridden”: If, for example, an isolated setting contains a User value, this value will
apply to the User. All other settings which have not been changed by the User will be read from the Administrator
profile. The same principle applies to settings in derived configurations: If a setting in a derived configuration con-
tains neither User values nor Administrator values, the superordinate configuration will be checked etc.

How do | achieve for several workstations that the administrator profile applies to all
users?

If the Database is located on the server, nothing more needs to be done. To prevent the settings from being over-
ridden by user-specific settings that might exist, all User values should be deleted (select the corresponding User in
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the User Management and select Delete values). The User Management will only be active if you started the Con-
figuration Editor as Administrator.

In case of a local configuration database, use the Configuration Editor to export the settings on the configured com-
puter (with Administrator profile). In any case it makes sense to remove all user-specific settings that might still exist.

On all other computers, select File > Import to read in the exported XML file. All user-defined settings that might still
exist should be removed from all computers.

Which options for the changing of settings in the ConfigDB are available in the tem-
plate files (.csv)?

Extensive information on this topic can be found in the document "Working with User-Defined Configuration Tem-
plates" in our Wiki, at Product know-how > Whitepaper.
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Legal notes
© 2022 ISD ® Software und Systeme GmbH. All rights reserved.

This User Guide and the software described herein are provided in conjunction with a license and may only be used or copied in accordance with
the terms of the license. The contents of this User Guide solely serve the purpose of information; it may be modified without prior notice and may
not be regarded as binding for the ISD Software und Systeme GmbH. The ISD Software und Systeme GmbH does not assume any responsibility
for the correctness or accuracy of the information provided in this document. No part of this document may be reproduced, saved to databases
or transferred in any other form without prior written permission by the ISD Software und Systeme GmbH, unless expressly allowed by virtue of
the license agreement.

All mentioned products are trademarks or registered trademarks of their respective manufacturers and producers.
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