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Configuration Management
As of Version 1700, HiCAD enables a central configuration management via the Configuration Editor . This tool
allows the creation of customer-specific configurations for a wide range of tasks, such as dimensioning, annota-
tion, workshop drawing creation, fitting of vertical ladders etc. Once adjusted to company-specific requirements,
these configurations can directly be used in HiCAD, without having to specify any further settings.

The goal of our further developments is a gradual transfer of the previously used system files (*.DAT) with their
adjustable parameter settings into the Configuration Editor, thus enabling a central and safe configuration man-
agement.

You can find an overview of the already transferred DAT files in the topic Transfer of DAT Files to the Configuration
Editor or in the PDF file Key names.pdf.

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link and
select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the PDF
file ISD-Configuration.pdf.

Range of features
n Hierarchical management of configuration data in the form of module properties

Settings are assigned to modules and sub-modules in a tree-like structure, and represent properties defining the
Behaviour of a module. The categorization facilitates the retrieval of individual settings.

n Central data storage

The configuration data are centrally stored in a database file in a defined location within the user system, which
enables an easy backing up, restoring or copying of data.

n User-specific data storage

The property definitions are stored separately from the actual user settings. This allows a working in multi-user
environments while eliminating the risk that a user accidentally manipulates the configuration of other users.

n Derived configurations

ConfigurationManagement allows, in addition to the basic configuration supplied by the ISD, the utilisation of
further, derived configurations for a definition of company- and/or team-specific settings. Furthermore, you
have the option to offer to users alternative configurations within one derivation level.

n Central administration of settings via one common graphical Configuration Editor

Eliminates the need for time-consuming and error-prone manipulations in configuration files. The integrated val-
idation of setting values by ranges and selection lists minimizes the risk of incorrect configurations and system
crashes due to invalid values.

n Documentation of settings

Each setting has a multi-language short description and comments on the meaning of the setting values. The
Configuration Editor offers a full text search for property names, descriptions and comments.

n Update-ability of the database

The data storage in the form of user profiles enables an updating of underlying pre-settings, without having to
change existing user settings. Values that have not been changed by the user will automatically be assigned the
updated pre-settings.
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Please note that the scope of functions available to you depends on the configuration level of your product,
i.e. not all the functions described in the Helpmay be available in your product!

The range of selectable modules for a local license depend on the license that was purchased.
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Transfer of DAT Files to the Configuration Editor
As of Version 1700, HiCAD enables a central configuration management via the Configuration Editor . This tool
allows the creation of customer-specific configurations for a wide range of tasks, such as dimensioning, annota-
tion, workshop drawing creation, fitting of vertical ladders etc. Once adjusted to company-specific requirements,
these configurations can directly be used in HiCAD, without having to specify any further settings.

The goal of our further developments is a gradual transfer of the previously used system files with their adjustable
parameter settings into the Configuration Editor, thus enabling a central and safe configurationmanagement.

This transfer has already been realised for the following files:

n ALGPAR.DAT (as of 1800.0)

n BEMPAR.DAT (as of 1800.0)

n DIMENSIONING_SETTINGS.XML (as of 1800.0)

n STBEMPAR.DAT (as of 1801.0)

n KRPGEN.DAT (as of 1801.0)

n MASPAR.DAT (as of 1801.1)

n FITTABLE_SETTINGS.XML (as of 1801.0)

n TXTANSI.DAT (as of 1801.1)

n STABMPAR.DAT (as of 1802.0)

n AUBM3PAR.DAT (as of 1802.0)

n ALG3DPAR.DAT (as of 1901.0)

n SCHRIF.DAT (as of 1901.0)

n TXTFONT.DAT (as of 1901.0)

n FEATURE.DAT (as of 1901.0)

n LINPAR.DAT (as of 1901.0)

n SSWRITESTEP.DAT (as of 1901.0)

n NORM.DAT (as of 2000.0)

n PASSTAB.DAT (as of 2000.0)

n PASSTAB0.DAT (as of 2000.0)

n ANSGEN.DAT (as of 2100.0)

n PARAMASS.DAT (as of 2101)

n SSTINI3D.DAT (as of 2102)

n SSTINI.DAT (as of 2102)

n STB_PARAMETER.DAT (as of 2102)

n GRAPAR.DAT (as of 2201)

n KNTPAR.DAT (as of 2202)

n REF3D_ATTR_AKT.DAT (as of 2300)

n TXTPAR.DAT (as of 2300)

n TABPAR.DAT (as of 2400)
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n ABWPAR.DAT (as of 2402)

n ABWCOL.DAT (as of 2402)

The settings from the files were transferred to the Configuration Editor. The linked lists or the PDF file shows you
where to find the settings from the DAT files in the Configuration Editor (Key names).

Key names.PDF

If the PDF file will not be displayed in the Internet Explorer, use a different browser , or right-click on the link and
select Save target as.

Various information contained in the Online Help of the Configuration Management can also be found in the PDF
file ISD-Configuration.pdf.

8 / 38 HiCAD ConfigurationManagement

Transfer of DAT Files to the Configuration Editor

https://help.isdgroup.com/help/1033/2019/hicad/schluesselname.pdf
https://help.isdgroup.com/help/1033/2019/hicad/isd-configuration.pdf


User Interface
The Configuration Editor enables an editing and managing of configuration. It provides a generic, hierarchical view
of the data and structures contained in the database.

You start the Configuration Editor outside of HiCAD, by executing the file ISDCONFIGEDITOR.EXE in the EXE dir-
ectory of HiCAD.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

Users without administrator rights and users with administrator rights who did not select the Run as administrator
option upon start:

n In the Editor, settings can be edited in the profile of the user who is currently logged onWindows.

n The switching to a different user is not possible. The selection box is greyed out.

Users with administrator rights who have selected the Run as administrator option (right-click and select from con-
text menu) upon start:

n The administrator profile can be changed in the Editor.

n The switching to other existing profiles is possible via the selection box, which enables a checking and/or chan-
ging of the configurations of various users.

You can also start the Configuration Editor directly from HiCAD: At the top right corner of the HiCAD window, select
Settings > Configuration.

You require administrator rights to start the Configuration Editor!

The user interface of the Configuration Editor consists of the following areas:

1. Menu bar

2. Toolbar

3. Search function

4. User selection

5. Current configuration structure tree

HiCAD ConfigurationManagement 9 / 38
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6. Data record of active configuration

7. User Management

8. Path of the currently selected structure item

9. Version and name of the configuration database

Important:

Changes in the Configuration Editor will only take effect after you re-start HiCAD. Only some particular settings,
such as dimensioning pre-settings, can be applied, via the corresponding HiCAD functions, without a re-start.

Menu Bar
The menu bar of the Configuration Editor contains the following menus:

n File

n Edit

n View

n Extras

Please note:

Some of the function in the menus will only be active when a data record has been selected in the right pane of the
window.

File

Export and import of setting values

The structure and the values of the configuration can be written to a XML file with the Export function. The export
function refers to the currently selected item in the configuration tree. The exported settings can then be imported,
for example, to another configuration database.

Edit
The configuration database administers values on the basis of user-specific setting profiles.

When you select a data record in the tree structure in the left pane of the dialogue window, the corresponding set-
tings will be displayed in the right pane of the window. You can use the functions of the Edit menu to modify these
values and the tree structure.

The changes will take effect after you re-start HiCAD.

Function Description

Change If you want to change a value in a data record, activate the desired item and select Change.

You can also activate the value via double-click or by pressing the F2 key, and then overwrite
it.

Changed values, i.e. values deviating from the underlying profile level, are marked appro-
priately and can be reset to the original default value at any time.
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Function Description

Reset This function restores the values in the active directory to the state in the database.

For instance, if you have modified the default settings of the dimensioning rules in various dir-
ectories, you can right-click the Usage-dependent entry, choose Reset, and, after con-
firming the security prompt with, restore the modified settings to defaults again. If you
confirm with Yes, a backup ([Installation directory] > Configuration > HiCAD.cfgdb.[Date])
will be created, in case youmay require the modified settings later again. If you choose No,
the values will be reset without creating a backup.

If you have marked only one value, only this value will be reset.

Copy key Use this function to copy the names of the marked key values in the right window, for
example, to a TXT file.

Rename Use this function to rename derived structures and derived configurations in the tree struc-

ture. The derived structure will be identified by the icon.

Delete This function deletes only derived structures and derived configurations in the left pane of
the Configuration Editor.

Derive struc-
ture

Use this function to copy the selected branch in the tree structure and paste it with a dif-
ferent name.

Select ref-
erence

If a referenced structure has been activated, this function activates the reference.

Activate con-
figuration

The 2nd level of the tree structure in the left pane of the Configuration Editor consists of the
areas:

n Active configuration and

n Configurations.

The configuration that you activate with this function will be displayed in the Active con-
figuration area and can then be modified.

Derive con-
figuration

Use this function to derive an alternative, complete configuration.

Here, too, the same principle as for structure derivation applies: Unchanged settings inherit
their values from the default values (ISD or Administrator profile) of the superordinate con-
figuration.

To edit the derived configuration, select Activate configuration.

Derive Configuration

Derived configurations have a tree-like structure and function according to the same principle as the overlaying of
values in user profiles, i.e. unchanged settings will inherit their values from the default values (ISD or Administrator
profile) of the superordinate configuration. Configurations on the same derivation level are independent from each
other.

To derive configurations, select Edit > Derive configuration. Derived configurations will be displayed in the left
pane of the window, under HiCAD >Configurations. The derivation will be created from the currently active con-
figuration.

To edit a derived configuration, select Edit > Activate configuration. The derived configuration will then be dis-
played under HiCAD > Active configuration and can be edited.

Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only create
derivations of company-specific configurations. To restore the ISD default settings, the configuration database
(HiCAD.cfgdb) must be re-installed.
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Derive Structure

Referenced and derived structures generate value inheritance lines. This enables you to create tree units (or indi-
vidual settings) that refer to a reference tree unit and obtain unchanged values initially from the default values of
the reference.

Example: Creation of a new drawing frame for workshop drawings

1. In the tree structure, select ... > Drawings > Drawing frames > DIN_A0. Then select Edit > Derive structure.

2. Change the displayed key to Drawings.Drawing frames.DIN_A5.

The structure DIN_A5 that will be created now will initially inherit all values from the reference structure DIN_A0.
This means that if one of the default values of DIN_A0 will be changed, this value will also change for DIN_A5. The
values of DIN_A5 can be assigned new default values. If a default value in the derived structure has been changed,
the value from the reference structure will no longer be inherited, i.e. changes of the corresponding value in the ref-
erence structure will no longer affect the derived value.

Use the Copy values option to take over changed values from a data record that is linked to DIN_A0, e.g. DIN_A3.

Updates of the reference structure containing new or deleted settings will be adopted by the derived struc-
ture.

View

Update

If you change the configuration settings in HiCAD while the Configuration Editor is open, the new settings will only
be displayed after activating the Update function.

Example:

When saving the rules set, the rules will be transferred to the Configuration Editor. The rules which are stored there
will be adjusted accordingly, new rules are added, or existing rules are deleted if required. After selecting Update,
the changes will become visible in the Configuration Editor.

Please note that HiCAD will apply the changes from the configurationmanagement only after restart.
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Display key names

HiCAD uses the key name to access the settings of the configuration management. The key name is identical in all
languages.

A description of this name is displayed in the standard view.

Example

View mode

The view mode enables the precise displaying of changed settings in the Configuration Editor.
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Normal All settings will be displayed in the Configuration Editor.

Only
changed
values

Only changed values of the current user profile, which are marked with the pencil icon , will be
displayed.

Only
changed
default
settings

This view mode is only activated if settings in the ISD profile were changed in an update and differ
from the company-specific default settings in the Administrator profile.

The company-specific Administrator profile will be saved in a logl file during an update. After-
wards the changed/new settings will be loaded into the ISD profile. At the end the logl file will be
loaded into the Administrator profile again.

If you load the company-specific Administrator profile after the update and select the Only
changed default settings function only the changed settings will be displayed. The values of the
changed settings stem from the company-specific Administrator profile.

When right-clicking on the value the Reset function can be activated. The setting from the ISD
profile which has been changed in the update will be displayed.

Extras

Language

You can currently select between English and German.
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Example

Database directory

For a HiCAD standard installation the database of the Configuration editor will be stored in the HiCAD installation dir-
ectory, at ...\Configuration\HiCAD.cfgdb.

The location of the database file will be entered into the Windows Registry at 

HKEY_LOCAL_MACHINE\SOFTWARE\ISD SOFTWAREUND SYSTEME\HICAD\[VERSION NUMBER]\HICAD.CFGD

To change the directory for the file, select Extras > Database directory. If you want to copy the database to the
new location, activate the same-named checkbox.

You can also change the path in HiCAD via Settings > Further directories. Before you do so, you need to copy the
database to the new directory.
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Toolbar
To enable a quick access, some of the functions of the menu bar are also contained in the toolbar:

Change If you want to change a value in a data record, activate the desired item and select
Change.

Reset This function restores the selected value to the state in the database.

Update If you change the configuration settings in HiCAD while the Configuration Editor is open,
the new settings will only be displayed after activating the Update function.

Collapse
all

This function collapses the structure display of the Configuration Editor and shows only
the 1st level.

Expand
2 levels

Shows you the first 2 levels of the configuration structure.

Expand
3 levels

Shows you the first 3 levels of the configuration structure.

Expand
all

Expands the complete structure display of the Configuration Editor.

Search Function
The Configuration Editor offers a full text search for value descriptions, comments and setting names. During the
process, the Editor browses through the structure, beginning (or continuing) at the currently selected node of the
configuration tree. Enter the desired search term and click the Find icon.

Search for data records

To perform a targeted search for particular entries (e.g. font or font size) in other data records, right-click the
desired data record and select Search value.
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In the search mask you can limit the search to a particular area of the configuration structure tree, by activating the
Limit to checkbox and selecting the area of the configuration structure from the drop downmenu.

When you click the Find button, HiCAD will jump to the next data record that meets the specified search criteria.
You can change this data record if desired, and continue your search.

User
The configuration database manages values on the basis of user-specific setting profiles. Two pre-defined profiles,
namely ISD and Administrator, have a special function.

The ISD profile forms the basis for the settings. In this profile, the HiCAD settings preset by the ISD are contained.

The Administrator profile allows the creation of company-wide default settings deviating from the ISD defaults. In
the process, the Administrator profile constitutes a level overlaying the ISD profile: Unchanged values will be read
from the ISD profile, so that changes of the ISD settings will automatically be transferred to the Administrator profile
(and thus also to the superordinate user profiles) when being updated. Modified, company-specific values will how-
ever be retained.

Profiles of other users overlay the Administrator profile according to the same principle, with each user profile being
independent of the other user profiles. If setting values are written from HiCAD into the database, this process will
always be performed via the profile of the user name currently logged on to Windows. In this way, an accidental
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changing of user settings, company-wide settings, or ISD default settings by other users via HiCAD will be pre-
vented.

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started:

n Users without administrator rights and users with administrator rights who did not select the Run as admin-
istrator option upon start:

l In the Editor, settings can be edited in the profile of the user who is currently logged onWindows.

l The switching to a different user is not possible. The selection box is greyed out.

n Users with administrator rights who have selected the Run as administrator option (right-click and select from
context menu) upon start:

l The administrator profile can be changed in the Editor.

l The switching to other existing profiles is possible via the selection box, which enables a checking and/or
changing of the configurations of various users.

To edit an entry, double-click a cell in the Value column, or select a cell and press the F2 key, or click the Change
icon on the Toolbar.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately can be reset to the
original default value at any time.

User Management
The integrated User Management allows the creation and deletion of user profiles, as well as the deletion or the tak-
ing over of user-specific values into other user profiles. In this way, for example, an Administrator is enabled to spe-
cify settings via HiCAD managed in the Configuration Editor. These are initially saved in his/her Windows user
profile, and can later be taken over to the administrator profile as company defaults, and will then apply to all users.

Click the icon to call the User Management. The dialogue window is composed of the following tabs:

n Settings

n User

n Groups

Click the icon to close the dialogue window.

Important:

The permissions to change profiles or settings depend on the behaviour of the Editor when it is started.
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Settings

Activate the Same configuration for all users checkbox to switch off the User Management and the Permissions
Management. The settings will then always be written to the Administrator profile.

The User Management is by default deactivated when the configuration database is installed for the first time.

User
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User tab

Add Adds a new User to the table.

Rename Enables you to change a selected User name.

Delete Deletes the selected User without any further confirmation prompt.

Group
assign-
ment

The user rights are controlled via group assignments. A User can belong to several Groups.
Use the Group assignment button to select Groups for Users. The main Group of the User will
be highlighted if youmark this Group and then click the As default button. The main Group will
be available during the configuration selection of the User. Click OK to exit the Group selec-
tion.

Adopt val-
ues

Use this function to apply the values of a selected User to the active User.

Delete val-
ues

Deletes the changed values of the selected User, thus restoring the values to that of the admin-
istrator profile / the values preset by the ISD.

Table
column:
Active con-
figuration

The Configuration Editor allows the creation of different user configurations via the Derive con-
figuration function. One of these configurations and the Base configuration can be assigned to
the User in the Active configuration column.

Please note:

HiCAD will use the Windows Login name in case of an utilisation via HiCAD, i.e. these names need to match when
users are created.
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Groups

Group tab

Add Adds a new Group to the table.

Rename Enables you to change a selected Group name.

Delete Deletes the selected Group without any further confirmation prompt.

Table
column: Act-
ive con-
figuration

The Configuration Editor allows the creation of different user configurations via the Derive
configuration function. One of these configurations and the Base configuration can be
assigned to the Group in the Active configuration column.

Permissions
for: e.g.
Designers A

The rights of a Group can be specified in the Permissions for: ... area, by activating the cor-
responding checkboxes. If a User belongs to several Groups, the activated rights of these
additional Groups are also available to him/her.

The permissions enable you to specify, for example, that a User can only read the settings
defined by the administrator, but not define and save his/her own settings, thus ensuring com-
pany-wide, identical settings.

Please note:

n The permissions that are assigned here apply globally, i.e. for all Users of the Group.

n Use the Permissions function if you want to assign permissions for sub-trees of the configuration. You can then
define permissions for Users and Groups .

Configuration Structure
The left pane of the Configuration Editor dialogue window contains the following entries (below HiCAD):
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n Active Configuration and

n Configurations.

Under Active configuration you will find the current HiCAD settings.

Under Configurations you can find the base configuration and all derived configurations of the active user. Use the
Derive configuration function to load data into the Active configuration area. There, you can activate individual
data records and edit them in the right pane of the dialogue window.

Important:

To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only create
derivations of company-specific configurations. To restore the ISD default settings, the configuration database
(HiCAD.cfgdb) must be re-installed.

Data Record
In the right pane of the Configurator Editor you can edit the data records that you activate in the left pane of the win-
dow. The data record consists of the Description, the Value and the Comment. When you display the key name via
View > Display key names, the system name of the entry will be additionally displayed.

You define your individual profile for HiCAD via the setting of values. The values are not always numerical values.
They may also be:

n a unit of measurement (mm, cm, ...)

n a string ("Collection")

n a key name

n a free entry

n a checkmark (e.g. to activate the display of a query etc.)
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n a procedure (Always, Dependent on dimension plane, etc.)

n an entry from the Catalogue Editor

n a selection of attributes.

Changed values, i.e. values deviating from the underlying profile level, are marked appropriately and can be reset to
the original default value (right-click and select Reset) at any time.

Some data records can be expanded by new data record entries.

Important:

n Changes made in the Configuration Editor will only take effect after restarting HiCAD.

n To prevent an accidental overwriting of the base configuration, i.e. the ISD default setting, you should only cre-
ate derivations of company-specific configurations. To restore the ISD default settings, the configuration data-
base (HiCAD.cfgdb) must be re-installed.

Change a value in an input field

If you want to change the value of a data record, right-click the corresponding row and select Change. You can also
double-click the row, or press F2, and then overwrite the value.
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Select a value from a listbox

Some settings are selected from a listbox.

Take value from catalogue

Click the symbol to select a value from the Catalogue Editor. Click the symbol to delete the setting again.
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Select a value by activating/deactivating of a checkbox

Some settings can be selected via activation or deactivation of a checkbox. In this example the user has activated
the setting of a symbol (e.g. a diameter symbol) for circular arc dimensions.

Referenced entries

In the tree structure, derived data records are marked with the symbol. The referenced entry in the right window
is marked with the symbol. If you change a referenced value, the referencing will be removed, and the changing
of the value will have no further effects any more.
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Multiple value selection

Some parameters allow a multiple value selection. Click the icon and select a combination of values from the
displayed list. Click OK to close the list. In the above example the position of an annotation tag for a bore is spe-
cified via a multiple selection.

Collection

If you are asked for a Collection you can select a template file. Click the icon and edit the template files in the
displayed list.
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To create your own template files, just copy one of the templates supplied by the ISD and adjust it according to your
individual needs. Save the templates to the HiCAD directory templates/… to enable them to be displayed in the Con-
figuration Editor.

IDs

These are values that refer to other HiCAD files, e.g. tables in the HiCAD catalogues.

In the above example the values (IDs) refer to the table Factory standards > User-defined materials > Civil Engin-
eering > Civil Engineering materials in the Catalogue Editor. This table has the ID 243732027.

In the Configuration Editor the ID entries in the rows determine the selection for the Sealing function. You can
select between the Type (Own production or Available on site), and the Material (Foil, Acrylic, Silicon, Sealing cord).

243700039 > Foil, Available on site

243700038 > Foil, Own production

243700031 > Acrylic, Available on site

243700032 > Acrylic, Own production

243700029 > Silicon, Available on site

243700030 > Silicon, Own production

243700027 > Sealing cord, Available on site

243700028 > Sealing cord, Own production
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Add new data record entry

In some areas you have the options to add new data record entries, or new groups with data record entries. To do
this, click the New group button, enter a name and click OK. The group will then be added and an empty data
record entry will be shown. When you now click on the input fields, you can compose the data record entry from the
values in the displayed selection boxes.
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Permissions
Permissions in the Configuration Editor basically function in the same way as the Windows file system permissions.
A typical use case is the granting or withdrawing of the permission Change property value - either for all values (via
the context menu of the configuration) or for a sub-tree within the configuration structure, including all values imme-
diately below (via the context menu of the uppermost item of the sub-tree).

Permissions can be assigned in a User-based or Group-based way. By default, each User (except for the Admin-
istrator) belongs to the Group Everyone. If in the Group Everyone the permission Change property value is with-
drawn, “normal” Users do no longer have the rights to change any values. Changed values in HiCAD dialogues, too,
will then no longer apply if they are stored in the configuration management. It is then possible to re-assign per-
missions, e.g. for a particular value or a sub-tree within the configuration structure, to individual Users. Also, Users
can be assigned to other Groups who have different permissions. If a User has no write permissions for a value, this

will be indicated (in an activated User profile) by the icon.

Select Edit > Permissions. The Permissions... dialogue window will be displayed. In the caption of the dialogue you
will also see the name of the currently selected item in the configuration structure (in the example below this is the
item “Drawing”).
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Example

Select the User whose permissions you want to change. Then, specify via the Accept and Deny checkboxes, which
permissions are to be granted to the User. Click the Apply button to apply the current settings without closing the
dialogue window. Select OK to apply the current settings and close the window.

Please note:

The granted permissions depend, in addition to the selected item in the structure, on the currently active/selected
configuration. For example, it is possible to grant permissions starting from a specific configuration derivation level.

Use Settings in HiCAD
All changes made in the Configuration Editor will take effect after a restart of HiCAD. Certain settings, such as pre-

settings for 2-D dimensioning, can be used in HiCAD immediately after selecting the Reload function (2-D

Dimensioning + Text > Edit > ).

Use the Load parameters function (3-D Dimensioning + Text Tools > Dimensioning > Tools ) to take
over the settings of the BEM3DPAR.DAT file.
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Scenarios
Below you will find some possible scenarios when using the ConfigurationManagement:

n How do I create a user-specific configuration if a use a standalone installation?

n How do I create a user-specific configuration if I work within a network?

n How do I switch between different configurations?

n How do I, as an administrator, assign different rights and settings to various users?

n How do I transfer the settings of a user to the administrator profile?

n I am already a HiCAD user. What effect will an update have onmy configuration settings?

n How do I transfer settings from HiCAD 2017 or 2018 to the Configuration database after installing HiCAD 2019
(new installation)?

n What needs to be done in case of an update from a version older than HiCAD 2011 to HiCAD 2013?

n Why are suddenly new users added to the configurationmanagement of the configuration database, and how
do I prevent individual users from changing their settings?

n How can I combine locally saved configuration databases with different settings for individual users into one,
central database without losing the settings for the individual users?

n Which settings have priority if administrator settings are different from user settings?

n How do I achieve for several workstations that the administrator profile applies to all users?

n Which options for the changing of settings in the ConfigDB are available in the template files (.csv)?

How do I create a user-specific configuration if a use a standalone installation?
In this case you are “your own administrator”, so to speak. If you want to change any settings, start the con-
figuration Editor and change the administrator profile.

Important:

Settings which are saved via HiCAD, e.g. 3-D dimensioning settings, will be saved to the profile of the User who is
currently logged onto the operating system, overriding the settings in the administrator profile. If any values are not
available in HiCAD as expected, please check if there are user-specific settings for these values.

How do I create a user-specific configuration if I work within a network?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) and derive a new
configuration. In the User Management, assign the corresponding configuration to the desired User profile. You
can also assign the configuration to the main Group of the User. In this way you ensure that all Users of the same
main Group will use this configuration.

Switch to the User profile and edit the required settings.

If no derived configuration is required, you can also simply edit the settings after activation of the User profile in the
base configuration.
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How do I switch between different configurations?
To switch between configurations, select Edit > Activate configuration on the menu bar.

General information on how to activate configurations can be found in the topic User Management.

Please note:

n The permissions assigned here apply globally, i.e. to all Users of the Group.

n Select Edit > Permissions to assign permissions to sub-trees of the configuration. You can then define per-
missions for Users and Groups.

n Use the User Management option to activate configurations for several Users or Groups. Assign the desired
configuration to the Users or Groups.

How do I, as an administrator, assign different rights and settings to various users?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).

Use the Permission function to assign rights.

Permissions in the Configuration Editor basically function in the same way as the Windows file system permissions.
A typical use case is the granting or withdrawing of the permission Change property value - either for all values (via
the context menu of the configuration) or for a sub-tree within the configuration structure, including all values imme-
diately below (via the context menu of the uppermost item of the sub-tree). Permissions can be assigned in a User-
based or Group-based way.

How do I transfer the settings of a user to the administrator profile?
Start the Configuration Editor as Administrator (right-click icon and select Run as administrator) .

Select the User Administrator.

Click the icon on the right. The User Management dialogue window will be displayed. In the dialogue, mark the user
whose values you want to apply.
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Click the Adopt values button to transfer the values of the marked user into the active administrator profile.

I am already a HiCAD user. What effect will an update have on my configuration set-
tings?
When performing an update from HiCAD 2017 or HiCAD 2018, your settings from the existing configuration file
HICAD.CFGDB of your previous HiCAD version will be transferred to the Configuration Management of HiCAD
2019, namely into the Administrator profile.

When the update is performed, only the values predefined by the ISD, i.e. the “factory settings”, will be changed.
All other (administrator or user) settings will be preserved.

If you use a central configuration database on a server, it will be automatically detected by the update program by
means of the corresponding Registry entry and will be updated. For an update of several workstations, one single
update will be sufficient; a multiple update will, however, not do any harm either (as an already updated setting will
not be updated again).

How do I transfer settings from HiCAD 2016 or 2017 to the Configuration Database
after installing HiCAD 2018 (new installation)?
If you perform a (new) installation of HiCAD 2019, the settings predefined by the ISD will be initially used in the
Administrator profile of the Configuration Management. If you want to transfer your individual settings in the file
HICAD.CFGDB from HiCAD 2017 or HiCAD 2018 to the Configuration Management of HiCAD 2019, use the pro-
gram CfgDbTool.exe in the HiCAD EXE sub-directory for this.

Furthermore, you are enabled to transfer settings from old DAT and XML files which are now managed in the Con-
figuration Editor, to the configuration database of Version 2019.

Proceed as follows:

1. Start the CfgDbTool.exe program in the HiCAD EXE sub-directory.

Use the Update tab of the CfgDBTool you tab to transfer the settings of your previous configuration file (.CFDB) to
the configuration file of Version 2019.
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2. Select the directories.

Update tab

Installed
database

The configuration database to be updated, i.e. (the previous configuration database of HiCAD).

Update
source

The configuration database of the new version; the configuration database with the current ISD
settings can be found in the folder: [HiCAD installation directory]\Configuration.

Update
target

The result of the update. If you enter the same file here as in the Installed database, a backup of
the previous configuration database will be created. You cannot enter the same database here
that you entered in the Update source field.

3. Click the Update button to start the process.

Use the Migrate tab to transfer your individual settings from old DAT and XML files which are now managed in the
Configuration Editor, to the configuration database of Version 2019.

The setting files with their adjustments need to be copied to the HiCAD SYS subdirectory of the new HiCAD version
for this purpose.

1. Start the CfgDbTool.exe program in the HiCAD EXE sub-directory and activate the Migrate tab.

34 / 38 HiCAD ConfigurationManagement

Scenarios



2. Select the directories.

Migrate tab

Base
folder

Here you enter the directory where your old DAT and XML files etc. are located. Please make
sure that the old files have the same name and are located in the same directory structure as in a
HiCAD standard installation.

Target
database

Here you specify the database to which the data are to be transferred.

3. Click the Migrate button to start the process.

What needs to be done in case of an update from a version older than HiCAD 2011 to
HiCAD 2013 (or higher)?
The new Configuration Management has been introduced with HiCAD 2011. Therefore you need to perform a new
installation for HiCAD 2013.

Since the Configuration management has not been supported in versions older than HiCAD 2011, a manual transfer
of your individual settings in the aforementioned DAT files to the Configuration Management, via the settings on the
Migrate tab of the program CfgDbTool.exe.

The PDF file schluesselname.PDF shows you where the settings from the old DAT files can now be found in the Con-
figuration Editor.

Why are suddenly new users added to the configuration management of the con-
figuration database, and how do I prevent individual users from changing their set-
tings?
If, for example, a user saves the 3-D dimensioning settings via HiCAD, the corresponding user name will be auto-
matically created in the User Management of the configuration database; the new User will be assigned to the user
Group Everyone by default.

If you (as Administrator) want to prevent a (new) User from saving his/her individual settings, assign only read per-
mission to the Group Everyone. When the user now tries to save the settings via HiCAD, a new User will still be
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created in the User Management, but the user-specific settings themselves will not be saved. Instead, the con-
figuration defined by the Administrator continues to apply.

How can I combine locally saved configuration databases with different settings for
individual users into one, central database without losing the settings for the indi-
vidual users?
Copy the configuration database of a computer to the unlocked server directory. Then, export the active con-
figuration on the other computers and import them to the central database again. Assign, via the User Man-
agement, to each User the corresponding configuration.

On the individual workstations, adjust the Registry entry for the storage location of the database.

Start the Configuration Editor as Administrator (right-click icon and select Run as administrator).

Which settings have priority if administrator settings are different from user settings?
User-specific settings override Administrator settings. Settings in derived configurations override settings in the
superordinate configuration.

Only individual values will be “overridden”: If, for example, an isolated setting contains a User value, this value will
apply to the User. All other settings which have not been changed by the User will be read from the Administrator
profile. The same principle applies to settings in derived configurations: If a setting in a derived configuration con-
tains neither User values nor Administrator values, the superordinate configuration will be checked etc.

How do I achieve for several workstations that the administrator profile applies to all
users?
If the Database is located on the server, nothing more needs to be done. To prevent the settings from being over-
ridden by user-specific settings that might exist, all User values should be deleted (select the corresponding User in
the User Management and select Delete values). The User Management will only be active if you started the Con-
figuration Editor as Administrator.

In case of a local configuration database, use the Configuration Editor to export the settings on the configured com-
puter (with Administrator profile). In any case it makes sense to remove all user-specific settings that might still
exist.

On all other computers, select File > Import to read in the exported XML file. All user-defined settings that might
still exist should be removed from all computers.

Which options for the changing of settings in the ConfigDB are available in the tem-
plate files (.csv)?
Extensive information on this topic can be found in the document "Working with User-Defined Configuration Tem-
plates" in our Wiki, at Product know-how > Whitepaper.
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